summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-12 19:45:30 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-12 19:45:30 +0000
commit8548d4d17e26b99afb9cf7728d97af6304f535a1 (patch)
tree0358a4f1a448843205cf7a2771bde2fdac606344 /app-text
parentapp-admin/entr: Clean up old. (diff)
downloadgentoo-8548d4d17e26b99afb9cf7728d97af6304f535a1.tar.gz
gentoo-8548d4d17e26b99afb9cf7728d97af6304f535a1.tar.bz2
gentoo-8548d4d17e26b99afb9cf7728d97af6304f535a1.zip
app-text/tidy-html5: Version bump.
Gentoo-Bug: https://bugs.gentoo.org/579764 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text')
-rw-r--r--app-text/tidy-html5/Manifest1
-rw-r--r--app-text/tidy-html5/tidy-html5-5.2.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/tidy-html5/Manifest b/app-text/tidy-html5/Manifest
index d0c4cfade516..6263ba925465 100644
--- a/app-text/tidy-html5/Manifest
+++ b/app-text/tidy-html5/Manifest
@@ -1 +1,2 @@
DIST tidy-html5-5.1.9.zip 1077163 SHA256 1c414aea63e168c5d28ec8aad047d68e12d07f67b891f4450252d0cb68154fab SHA512 a5f18d43333f5acb6a4290bd9960fbccb1fa07b180ac3e02ee0a1ec890fd3ebef6f0f2811df05f9808220945d9810f94059f328c2d0d6827543c6697d73e0dc5 WHIRLPOOL 8b10a34ce247077c9f7450b41fbbd0135f0a88214445adddbbf70bdb296d541b75188d491961e3f9fde465c80b1e09d060160e5c0609c9ba923548ad2981aa04
+DIST tidy-html5-5.2.0.zip 578494 SHA256 7f6ef14e41a0e9611fcb95e4926287e0d4a46c53335ae7e3aa4fc11ae69d32e2 SHA512 0559bbe24711606b391057b3dbf2692b54e548294f68b310be306b5be80c9265ba7c4aa8da2b13ba0c89dae1dd6d233aebebdba761e25193439a0c0d713e59d8 WHIRLPOOL 7040ad176d2a96936cf250afc16f8376c9febd80ef98976bca318407299e52896c34a23964654efb1d69a2bf49438f6402d4af9d140ce45f6fe7d27bda010dce
diff --git a/app-text/tidy-html5/tidy-html5-5.2.0.ebuild b/app-text/tidy-html5/tidy-html5-5.2.0.ebuild
new file mode 100644
index 000000000000..6220f310982c
--- /dev/null
+++ b/app-text/tidy-html5/tidy-html5-5.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Tidy the layout and correct errors in HTML, HTML5 and XML documents"
+HOMEPAGE="http://www.html-tidy.org/"
+SRC_URI="https://github.com/htacg/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-text/htmltidy"
+
+S="${WORKDIR}/${P}"
+
+DOCS=( README/{CODESTYLE,README,CONTRIBUTING,LICENSE,VERSION}.md )
+HTML_DOCS=( README/README.html )
+
+BUILD_DIR="${S}/build/cmake"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_BUILD_TYPE=Release
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cd build/cmake || die
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}