summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-28 23:35:10 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-29 00:05:46 +0200
commit8d8c30d9715c2987513e5e539a918fc67bb5b618 (patch)
treef7674476a37174f4260ffbcc459b1088d74588b5 /app-text
parentdev-java/avalon-logkit: Remove old 1.2.2-r2 (diff)
downloadgentoo-8d8c30d9715c2987513e5e539a918fc67bb5b618.tar.gz
gentoo-8d8c30d9715c2987513e5e539a918fc67bb5b618.tar.bz2
gentoo-8d8c30d9715c2987513e5e539a918fc67bb5b618.zip
app-text/iso-codes: version bump 3.74 → 3.75
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-text')
-rw-r--r--app-text/iso-codes/Manifest1
-rw-r--r--app-text/iso-codes/iso-codes-3.75.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 56040c44f891..3f1fcd59bfd4 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1 +1,2 @@
DIST iso-codes-3.74.tar.xz 3455148 SHA256 21f4f3cea8fe09f5b53784522303a0e1e7d083964ecaf1c75b1441d4d9ec6aee SHA512 b4d583a6aee331c2cdf7cdd68a0ef5e7c3b291c4afa9a9a636e9fe2aef54e784cec070f5b8fafb31e8c84b278e1a9b08d7f925187882f7382378b66778e0d9cb WHIRLPOOL 0e83c3c7fcc3f21b1b5aacd003c65550dc896cb3bb4eff0fc8a5719870a7ce4ce3fe2da8ea6e3a5ab47512d3137a1b331c2880999534d82c34b5bbf1a91d3663
+DIST iso-codes-3.75.tar.xz 3461424 SHA256 7335e0301cd77cd4ee019bf5d3709aa79309d49dd66e85ba350caf67e00b00cd SHA512 157899048cec091864ad8a7723314e28a0ccc4a0e1a5c2101bb630baf1a034bf117e38263e3c95e0135ba9d3a4d76635c8201c50a54e25f6af24c87253b8b40e WHIRLPOOL 33488e9a89217b3e1b0f1bad93168f7acb6b8f4693dffa6b8c417cd1dbbeff47a1cd63b82dec3aa879a8f1df7205114f934815acd8117f14bfcbc865a89b49f7
diff --git a/app-text/iso-codes/iso-codes-3.75.ebuild b/app-text/iso-codes/iso-codes-3.75.ebuild
new file mode 100644
index 000000000000..64c8a46ae42e
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.75.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+PLOCALES="af am ar as ast az be bg bn bn_IN br bs byn ca crh cs cy da de dz el en eo es et eu fa fi fo fr ga gez gl gu haw he hi hr hu hy ia id is it ja ka kk km kn ko kok ku lt lv mi mk ml mn mr ms mt nb ne nl nn nso oc or pa pl ps pt pt_BR ro ru rw si sk sl so sq sr sr@latin sv sw ta te th ti tig tk tl tr tt tt@iqtelif ug uk ve vi wa wal wo xh zh_CN zh_HK zh_TW zu"
+
+inherit eutils l10n python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="http://pkg-isocodes.alioth.debian.org/"
+SRC_URI="http://pkg-isocodes.alioth.debian.org/downloads/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${PYTHON_DEPS}
+ app-arch/xz-utils
+ sys-devel/gettext
+"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+# l10n_find_plocales_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if use "linguas_${loc%.po}"; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}