summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-01-05 13:48:46 +0100
committerFabian Groffen <grobian@gentoo.org>2018-01-05 13:52:24 +0100
commit90bf1a7c527ccdb703581cd57150020dff72762c (patch)
tree9cf2ef0805e06e9d074ca103172290eef19ebb01 /app-text
parentapp-text/antixls: fix homepage/src_uri, bug #626676 (diff)
downloadgentoo-90bf1a7c527ccdb703581cd57150020dff72762c.tar.gz
gentoo-90bf1a7c527ccdb703581cd57150020dff72762c.tar.bz2
gentoo-90bf1a7c527ccdb703581cd57150020dff72762c.zip
app-text/antixls: EAPI-bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-text')
-rw-r--r--app-text/antixls/antixls-0.3b.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-text/antixls/antixls-0.3b.ebuild b/app-text/antixls/antixls-0.3b.ebuild
index a29d5e2b75c7..53e29234db59 100644
--- a/app-text/antixls/antixls-0.3b.ebuild
+++ b/app-text/antixls/antixls-0.3b.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
DESCRIPTION="Print out an XLS file with minimal formatting, or extract the data into CSV"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.perl"
@@ -9,8 +11,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE=""
DEPEND="dev-perl/Spreadsheet-ParseExcel"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}/${P}.perl" "${S}"/${PN} || die
+}
src_install() {
- mv "${DISTDIR}/${P}.perl" ${PN}
dobin ${PN}
}