summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-19 20:14:03 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-19 20:14:03 +0100
commit960f7959d72bd1e899f995718bfa432814a1aa02 (patch)
tree64226d2750d6f2bd4cf482ce20720fb2ed581b15 /app-text
parentgnome-base/gnome-shell: Drop old (diff)
downloadgentoo-960f7959d72bd1e899f995718bfa432814a1aa02.tar.gz
gentoo-960f7959d72bd1e899f995718bfa432814a1aa02.tar.bz2
gentoo-960f7959d72bd1e899f995718bfa432814a1aa02.zip
app-text/gspell: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-0.1.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 0753a31a1b2e..519c4ae6a591 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1 +1,2 @@
DIST gspell-0.1.1.tar.xz 354932 SHA256 fef8cd89d220fc9ad6b69ff625ca2263a09c69ba56fcefcc90cf4422896e4c52 SHA512 aca0f3e9e9c8f3b4b7ebecc82aecb2f23782fad5192fb23a6737c23767cdff82c47e2d0d2d0d5540838f269d9a07895817ea405abada142b0f493306ad607087 WHIRLPOOL ebe1ba9fc0932eeec85191d012d1bc9734e69cfdf812ab09371aa8bdf5ef6ab49320cd80c81703ce8ec29737f558336a8505ef5ff945038b0a30ad61ec2918eb
+DIST gspell-0.1.2.tar.xz 355128 SHA256 e8625c57296b6c178bc37659f023342f8edefaaa2c5eccf40de8bd479dbfa8f0 SHA512 8d9bd61f378929217b9461debb58df5070952539f30f6ee211cf13f856dfe5d5216468679a8d7d7b08df47ee6b7b45f25b2b6400212a83de9563e2bf175905bb WHIRLPOOL 44334ac608e9a66c5a6bf011ad21d7d368e29d7923079e947ed5484ae0c7847df1f29dc255979d0da844e1ecba16fa19dfae5b84aefd85287bc63de1465d3ffa
diff --git a/app-text/gspell/gspell-0.1.2.ebuild b/app-text/gspell/gspell-0.1.2.ebuild
new file mode 100644
index 000000000000..d4bb07bcc899
--- /dev/null
+++ b/app-text/gspell/gspell-0.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection vala"
+
+RDEPEND="
+ >=app-text/enchant-1.6.0
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/libxml2-2.5.0:2
+ >=x11-libs/gtk+-3.16:3
+ >=x11-libs/gtksourceview-3.16:3.0
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.24
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}