summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-07 23:49:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-07 23:54:46 +0100
commit97cfb38fd7623cb94baff5e09a8a6b9088648886 (patch)
treebd1459c3532db8e4ab459c52ba500838ff7080f1 /app-text
parentapp-text/poppler: EAPI-7 bump (diff)
downloadgentoo-97cfb38fd7623cb94baff5e09a8a6b9088648886.tar.gz
gentoo-97cfb38fd7623cb94baff5e09a8a6b9088648886.tar.bz2
gentoo-97cfb38fd7623cb94baff5e09a8a6b9088648886.zip
app-text/poppler: 0.73.0 version bump
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/Manifest1
-rw-r--r--app-text/poppler/poppler-0.73.0.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index 017ccd81aed2..7091647900a7 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -2,3 +2,4 @@ DIST poppler-0.62.0.tar.xz 1423372 BLAKE2B 01c8745d0c1fa5b412ec92295a8784f5c1def
DIST poppler-0.68.0.tar.xz 1461052 BLAKE2B e95aa872230ff88f2caf9b8fef7da369b3115b1aabef2d57ebba3a13123ffe1cf1e200c6583a6da9e52bdb7708bec30e26f68e582bf99289abd572e42f712a5e SHA512 98449ab96db1d17901ec44b1a71b0375ac83d0f13e059b83afb452939a3ae6375c4667ae029fa333fad3eed2d8315e5f1208f34d3548c5530f0ecc7a5841c27a
DIST poppler-0.71.0.tar.xz 1480852 BLAKE2B be23100e44f73cd024d50727a632b749629b6e36ef41d2aee94f1998a8362dd0fa11e64bfb0f0f04f87265029abec32088ef2dad3b5aeb2733c44447aaeb6817 SHA512 8e0ce95e7b58c37761c36a20f1282e63373a9557bf9f746ce2936562f12648506043d9559cf816944aa238814fc1b3f3a3c0a6cb002fd214b067e399bcc6ab1e
DIST poppler-0.72.0.tar.xz 1492912 BLAKE2B 6582b418031c52e5e9031e9f25b80841ba471c1308030bef2cdb13cd607ddd0ca51639d93c09f33e42d5f9378ee44b5ebe4dbac29254f952f7c2ec147799bc5e SHA512 57dc98ff3e433cb8c7e3c31016c080e09586410622d70fb2fe1aa36c2a55017508dd5b5b253cfe987b86f9197bdd34345e038c89f542003cf021900c86614145
+DIST poppler-0.73.0.tar.xz 1507068 BLAKE2B d88a7595d0d8b779d623b56d8dc25c753f2cfc6f015092ec9d254a2b2d701d0e760a069324a15d3a03c65c9c85c3398ad142d7f8cc259e5455f53b4d391596d3 SHA512 6924a343032573504a0039c56a6263cd1183fa6aca75966fe1f084bd19da78553e455e541a3693896c1ed0c3865f11c11758a0f5a66b2f6cd48ac8a7eccf891a
diff --git a/app-text/poppler/poppler-0.73.0.ebuild b/app-text/poppler/poppler-0.73.0.ebuild
new file mode 100644
index 000000000000..05c24b50807e
--- /dev/null
+++ b/app-text/poppler/poppler-0.73.0.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/84" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+DEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ x11-libs/cairo
+ introspection? ( dev-libs/gobject-introspection:= )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
+ png? ( media-libs/libpng:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+RDEPEND="${DEPEND}
+ cjk? ( app-text/poppler-data )
+"
+
+DOCS=( AUTHORS NEWS README README-XPDF )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.60.1-qt5-dependencies.patch"
+ "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
+ "${FILESDIR}/${PN}-0.71.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.61.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if [[ ${CC} == clang ]] ; then
+ sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
+
+ # we need to up the C++ version, bug #622526, #643278
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ xdg_environment_reset
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
+ -DSPLASH_CMYK=OFF
+ -DUSE_FIXEDPOINT=OFF
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DENABLE_CMS=$(usex lcms lcms2 none)
+ -DWITH_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
+ $(cmake-utils_use_find_package qt5 Qt5Core)
+ -DWITH_TIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
+ )
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != *9999* ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}