summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-10-03 15:16:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-10-03 15:22:24 +0200
commit9d685b91037be6853ae348bea8c92afce87da8ee (patch)
tree4adb495a5cc4f2b8b6dd3e845f5271b8413868ea /app-text
parentapp-i18n/skkfep: amd64 stable (diff)
downloadgentoo-9d685b91037be6853ae348bea8c92afce87da8ee.tar.gz
gentoo-9d685b91037be6853ae348bea8c92afce87da8ee.tar.bz2
gentoo-9d685b91037be6853ae348bea8c92afce87da8ee.zip
app-text/lcdf-typetools: bump to 2.108.
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lcdf-typetools/Manifest1
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-text/lcdf-typetools/Manifest b/app-text/lcdf-typetools/Manifest
index c6e5dc8d88d7..f2f17c7c48a0 100644
--- a/app-text/lcdf-typetools/Manifest
+++ b/app-text/lcdf-typetools/Manifest
@@ -1,2 +1,3 @@
DIST lcdf-typetools-2.106.tar.gz 643503 BLAKE2B cb016da74dfbad92808292842de653badec4dd3b703fee5e177016856a795e1383ceeed68de668846cce167b7b9c74bd7e0b17ea3a60b2f9b9caa0b73444e02d SHA512 039215132585214e6518864161885f7a06f08f8b36b002a961b1d83182e388b31eb034eaa4466ba56a2af52e1cfb202e88f004be17c22df1343f94481e3114cf
DIST lcdf-typetools-2.107.tar.gz 652445 BLAKE2B bbbc428673c8e036f8d3be8ec80dbcf8892f60976fee7f11d622af8442c4d3eda0e118d47b364f55fe0dc8b53062ece0926be1d67e6627500a787bce810c074c SHA512 be54d4346d567c640b260dc513854085901af96b82701fccb8f0feae4b373ac69962c568a648515eb9ebfcabc828359ab2d742947ccdf9422643b0d889961ff3
+DIST lcdf-typetools-2.108.tar.gz 651350 BLAKE2B c60986672a31bcf47b876fa75d04a976be761442b04b1541f7f9082521d716708542b8708fd3da558f9df6b459cca1043a7e1ee2eb006f94054611dd4ef348d5 SHA512 2c7afe1c6838f432ddd5bbd5fa86a58743242d5a2203220d3cd0153c0c69f23ca734e8d4352ed3c8a6bffc1c61bb93c19d00c6483545a09d6f8363f870bf2fd0
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
new file mode 100644
index 000000000000..65192f6e24b3
--- /dev/null
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Font utilities for eg manipulating OTF"
+SRC_URI="http://www.lcdf.org/type/${P}.tar.gz"
+HOMEPAGE="http://www.lcdf.org/type/#typetools"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+kpathsea"
+
+RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ use kpathsea && has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ econf $(use_with kpathsea)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS.md README.md ONEWS
+}