summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-09-08 11:11:04 +0200
committerSebastian Pipping <sping@gentoo.org>2018-09-08 11:21:45 +0200
commit9f2c7aeed183c8c92f976239d28a1b5e64275c61 (patch)
tree791b41502da2e07896fc3598030b99f98022f42c /app-text
parentnet-misc/apt-cacher-ng: Old. (diff)
downloadgentoo-9f2c7aeed183c8c92f976239d28a1b5e64275c61.tar.gz
gentoo-9f2c7aeed183c8c92f976239d28a1b5e64275c61.tar.bz2
gentoo-9f2c7aeed183c8c92f976239d28a1b5e64275c61.zip
app-text/dvisvgm: 2.6
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-2.6.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index f5558761f7f2..5226a41f8577 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -6,3 +6,4 @@ DIST dvisvgm-2.3.5.tar.gz 2897194 BLAKE2B 7661d6f5ac097a6dc62cf873dee84ec47b55e4
DIST dvisvgm-2.4.2.tar.gz 2918538 BLAKE2B 373e2e6a017189dc130cc40f9abfd4601a1764400858860104e764757e93758a7d12c6b8125d684ba7a9d4bb21fe2820007852ea2e46f57cd3fe7d61d2a4d63b SHA512 9c2dbf088244898ce86a177d81cbf67bbae2df8703dce686016e2b455f6eea516751e84521f8097b82bd6a9e5b294043e3ee38cd470ff6ac1633a976828b99fc
DIST dvisvgm-2.4.tar.gz 2850942 BLAKE2B c1cdb4aed954bcb5704b83deba087403f366f0139b053b599029d103bd85306e58c7bffb1228d3ace02fd3be91eff002e6d1e45105bb8ccaa85945ba7bbf5210 SHA512 84f51fa8cbf0a32efe667321102b1705c613cc697d86d00df2e044cd97b1f390e1552af7da2891792ccef634507bbc6922f92f194f5acb7d05a48e268e708396
DIST dvisvgm-2.5.tar.gz 2911331 BLAKE2B b9ee90f5e34784d690f6a9a80dd1cdc4ce516f1e50722a93a0ea6e03da4f60f1bb983fa8abd8e670b2719afbf3197e6483a5c401fa1d668f79569d6a21701be2 SHA512 a722abb94c93ed8f7a6a91730639b7471b37c8c215297efe2ee071ff31829911c49253f17ccbb01dcea578ff55f2b179d85a0d9d32f65ed34ab18455e844578e
+DIST dvisvgm-2.6.tar.gz 2978741 BLAKE2B 342da9c26d05cf319053206d84e8c12ec3f3984b515f8fa6483a1ce5bf1748477f1119e8e03847a28c6458ba25229fd735a63122257450612fcc226a2e871441 SHA512 02fc3a92fe80d7146a1bc84eaa28fac714f533d9bcc3847993da978a66f533400c2c03019bb5efb3c16fcbf6774c565b1f6149cd15f4e04ae05304f879392b05
diff --git a/app-text/dvisvgm/dvisvgm-2.6.ebuild b/app-text/dvisvgm/dvisvgm-2.6.ebuild
new file mode 100644
index 000000000000..f4c0ba5ab26e
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-2.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="http://dvisvgm.bplaced.net/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+# Tests don't work from $WORKDIR: kpathsea tries to search in relative
+# directories from where the binary is executed.
+# We cannot really use absolute paths in the kpathsea configuration since that
+# would make it harder for prefix installs.
+RESTRICT="test"
+
+# TODO unbundle app-arch/brotli
+RDEPEND="virtual/tex-base
+ >=app-arch/brotli-1.0.5
+ app-text/ghostscript-gpl
+ dev-libs/kpathsea:=
+ >=dev-libs/xxhash-0.6.5
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ >=media-libs/woff2-1.0.2
+ dev-libs/kpathsea
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-text/xmlto
+ app-text/asciidoc
+ dev-libs/libxslt
+ virtual/pkgconfig
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local myargs=(
+ --without-ttfautohint
+ )
+ econf "${myargs[@]}"
+}