summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-06 22:51:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-07 09:54:00 +0200
commita6ffbf1fe25b2102f985ec1b86ad46f89c9a4516 (patch)
tree64bc2f58673e718c6765d624134092c7aba02833 /app-text
parentdev-util/kdevelop-python: 5.5.1 version bump (diff)
downloadgentoo-a6ffbf1fe25b2102f985ec1b86ad46f89c9a4516.tar.gz
gentoo-a6ffbf1fe25b2102f985ec1b86ad46f89c9a4516.tar.bz2
gentoo-a6ffbf1fe25b2102f985ec1b86ad46f89c9a4516.zip
app-text/libspectre: 0.2.9 version bump, EAPI-7 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libspectre/Manifest1
-rw-r--r--app-text/libspectre/files/libspectre-0.2.0-interix.patch6
-rw-r--r--app-text/libspectre/libspectre-0.2.9.ebuild54
3 files changed, 58 insertions, 3 deletions
diff --git a/app-text/libspectre/Manifest b/app-text/libspectre/Manifest
index 54fa010bd956..8afc9c293ae4 100644
--- a/app-text/libspectre/Manifest
+++ b/app-text/libspectre/Manifest
@@ -1 +1,2 @@
DIST libspectre-0.2.8.tar.gz 421791 BLAKE2B bbefa06cf80ecb91f0f780493e1829eadc34061b6f2b3004f9ae01e06fc4609edd440df290be9ff1c9f43e580b53791aae033feb4115743a0f03f703bc18e0c7 SHA512 ebbe7f6adcbc7f7d6af61f24e23b114116c878755dbe90f1163546c1284a005b4d539be01986c1f940611e84141ca19768b8effc2abf1013606da7c93547da86
+DIST libspectre-0.2.9.tar.gz 433384 BLAKE2B ed75a7013763a86c0f0702e0e47dcfb8401db6c957ed4851ecc85e27db6a49c8d4dae6443b302bcce5b0ae0da18dce3294a010eee5531a253020a650c19388c5 SHA512 7c24b5c83c6d356c89417d09dc76566afbe886ec189fe80d030a239c23ad25b061db071768117fa06805aa3d86f749fb232b7491bd7d467f26a40e348e74d5d2
diff --git a/app-text/libspectre/files/libspectre-0.2.0-interix.patch b/app-text/libspectre/files/libspectre-0.2.0-interix.patch
index 7b607542dfad..8f2956331852 100644
--- a/app-text/libspectre/files/libspectre-0.2.0-interix.patch
+++ b/app-text/libspectre/files/libspectre-0.2.0-interix.patch
@@ -1,6 +1,6 @@
-diff -ru libspectre-0.2.0.orig/libspectre/spectre-utils.c libspectre-0.2.0/libspectre/spectre-utils.c
---- libspectre-0.2.0.orig/libspectre/spectre-utils.c 2008-05-06 08:35:07 +0200
-+++ libspectre-0.2.0/libspectre/spectre-utils.c 2008-05-06 08:49:51 +0200
+diff -ru libspectre/spectre-utils.c libspectre/spectre-utils.c
+--- a/libspectre/spectre-utils.c 2008-05-06 08:35:07 +0200
++++ b/libspectre/spectre-utils.c 2008-05-06 08:49:51 +0200
@@ -148,6 +148,17 @@
spectre_strdup_vprintf (const char *format,
va_list args)
diff --git a/app-text/libspectre/libspectre-0.2.9.ebuild b/app-text/libspectre/libspectre-0.2.9.ebuild
new file mode 100644
index 000000000000..0053bce742ac
--- /dev/null
+++ b/app-text/libspectre/libspectre-0.2.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library for rendering Postscript documents"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libspectre"
+SRC_URI="https://libspectre.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug doc"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND=">=app-text/ghostscript-gpl-9.24"
+DEPEND="${RDEPEND}"
+
+# does not actually test anything, see bug 362557
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2.0-interix.patch )
+
+src_prepare() {
+ default
+ eautoreconf # need new libtool for interix
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug asserts)
+ $(use_enable debug checks)
+ --disable-test
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}