summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 05:41:52 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:15 +0100
commitab2c740cd2480772570fce7ab56b43310dc97c3c (patch)
tree7d0a0b4cb49fb5cc573392778c0906b44fc29014 /app-text
parentapp-text/ding: eutils->desktop in old (diff)
downloadgentoo-ab2c740cd2480772570fce7ab56b43310dc97c3c.tar.gz
gentoo-ab2c740cd2480772570fce7ab56b43310dc97c3c.tar.bz2
gentoo-ab2c740cd2480772570fce7ab56b43310dc97c3c.zip
app-text/htmlc: port to EAPI 7, drop eutils
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/htmlc/htmlc-2.40.0.ebuild10
-rw-r--r--app-text/htmlc/htmlc-2.60.0.ebuild18
2 files changed, 13 insertions, 15 deletions
diff --git a/app-text/htmlc/htmlc-2.40.0.ebuild b/app-text/htmlc/htmlc-2.40.0.ebuild
index 8f9c4893199b..488950ddc494 100644
--- a/app-text/htmlc/htmlc-2.40.0.ebuild
+++ b/app-text/htmlc/htmlc-2.40.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
# Override version: 2.4.0 > 2.21.0 so we name it 2.40.0
MY_P="${P/0[.]/.}"
@@ -9,6 +9,7 @@ MY_P="${P/0[.]/.}"
DESCRIPTION="HTML template files expander"
HOMEPAGE="http://htmlc.inria.fr/"
SRC_URI="http://htmlc.inria.fr/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
LICENSE="htmlc"
SLOT="0"
@@ -20,11 +21,9 @@ IUSE="+ocamlopt"
DEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
-
src_configure() {
./configure \
- --install-root-dir "${ED}usr" \
+ --install-root-dir "${ED}/usr" \
|| die
}
@@ -42,6 +41,7 @@ src_install() {
else
emake installbyt
fi
+
emake MANDIR='$(PREFIXINSTALLDIR)/share/man/man$(MANEXT)' installman
dodoc README Announce* CHANGES
}
diff --git a/app-text/htmlc/htmlc-2.60.0.ebuild b/app-text/htmlc/htmlc-2.60.0.ebuild
index b10f6905b522..38f7c831c39b 100644
--- a/app-text/htmlc/htmlc-2.60.0.ebuild
+++ b/app-text/htmlc/htmlc-2.60.0.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=7
# Override version: 2.4.0 > 2.21.0 so we name it 2.40.0
MY_P="${P/0[.]/.}"
@@ -11,6 +9,7 @@ MY_P="${P/0[.]/.}"
DESCRIPTION="HTML template files expander"
HOMEPAGE="http://htmlc.inria.fr/"
SRC_URI="http://htmlc.inria.fr/${MY_P%.0}.tgz"
+S="${WORKDIR}/${MY_P}"
LICENSE="htmlc"
SLOT="0"
@@ -22,15 +21,13 @@ IUSE="+ocamlopt"
DEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}/werror.patch"
-}
+PATCHES=(
+ "${FILESDIR}"/werror.patch
+)
src_configure() {
./configure \
- --install-root-dir "${ED}usr" \
+ --install-root-dir "${ED}/usr" \
|| die
}
@@ -48,6 +45,7 @@ src_install() {
else
emake installbyt
fi
+
emake MANDIR='$(PREFIXINSTALLDIR)/share/man/man$(MANEXT)' installman
dodoc README Announce* CHANGES
}