summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-08-24 15:37:40 +0200
committerMarek Szuba <marecki@gentoo.org>2020-08-24 19:07:23 +0200
commitb0516dc9d89a0279a33ba8c78b7eddfc9d429a3f (patch)
treec7f0ffa91c3de51c263d3a648b68b4a3451a1e5d /app-text
parentdev-libs/level-zero: bump to 1.0.0 (diff)
downloadgentoo-b0516dc9d89a0279a33ba8c78b7eddfc9d429a3f.tar.gz
gentoo-b0516dc9d89a0279a33ba8c78b7eddfc9d429a3f.tar.bz2
gentoo-b0516dc9d89a0279a33ba8c78b7eddfc9d429a3f.zip
app-text/bibletime: bump to 3.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibletime/Manifest1
-rw-r--r--app-text/bibletime/bibletime-3.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-text/bibletime/Manifest b/app-text/bibletime/Manifest
index 08f40b4010d6..689a11088bb3 100644
--- a/app-text/bibletime/Manifest
+++ b/app-text/bibletime/Manifest
@@ -1,2 +1,3 @@
DIST bibletime-2.11.0.tar.xz 2403136 BLAKE2B fecf854a40ad0e188fde8ad3d047acf6274bfdf20f6a6211a6ff9d41e3de38f4d311db92e2b2fdf735e293163637cf4b553e722a05174d8c84201e94cf6e7b7c SHA512 41f0751db30b9001d04e1c4040dca022c83eb440987104e2c3465f4233f8c0ecb1c940eac0433409f97f78c89c00d0f880f822a51219eadcbf3fc6513cfa81e6
DIST bibletime-2.11.2.tar.xz 2533472 BLAKE2B b116bbefaac8106d1f283d1c1a0c4d4c17e67d1cb41066c219ecca243914b0fa355748ebebb23ec88c1749548c853166d391764a454dd77b43c6617072a648a6 SHA512 99e2500e07797549e32ac28238c90a4db1cd98f74ea20f0161db7675127f42363006f20d859504be958bfdecf80a18a96229a1bbc105d332af97644fafc92d31
+DIST bibletime-3.0.tar.xz 1568732 BLAKE2B f1e9cb23d64d566d8b0934cfbdffabb52193f240523ad3ba79bbf0e3cd3ff516354791bf0b057354820cd3303c01d3ec50aa61f2e7843b1083c74d442d915a89 SHA512 85afc2781807345ea8fdefea6d179955fa76085c0a9c97e47321ea37ef9ea05367678c54bacfc10cf1d6085d46ba6fbd1c7d448044ffdfe3c96007ee8d7e5c00
diff --git a/app-text/bibletime/bibletime-3.0.ebuild b/app-text/bibletime/bibletime-3.0.ebuild
new file mode 100644
index 000000000000..599fd22e4549
--- /dev/null
+++ b/app-text/bibletime/bibletime-3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED=test
+
+inherit cmake virtualx
+
+DESCRIPTION="Qt Bible-study application using the SWORD library"
+HOMEPAGE="http://bibletime.info/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Some tests fail due to being unable to find an icon directory relative
+# to ${WORKDIR}, some others segfault. Needs work.
+RESTRICT="test"
+
+RDEPEND=">=app-text/sword-1.8.1
+ dev-cpp/clucene
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-libs/icu:=
+ dev-qt/linguist-tools:5
+ dev-qt/qttest:5
+ net-misc/curl
+ sys-libs/zlib"
+#BDEPEND="test? (
+# app-dicts/sword-Josephus
+# app-dicts/sword-KJV
+# app-dicts/sword-KJVA
+# app-dicts/sword-Scofield
+# app-dicts/sword-StrongsGreek
+#)"
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
+ -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_HANDBOOK_HTML=no
+ -DBUILD_HANDBOOK_PDF=no
+ -DBUILD_HOWTO_HTML=no
+ -DBUILD_HOWTO_PDF=no
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test || die "Test run has failed"
+}