summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-15 16:44:28 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-15 16:45:12 +0100
commitb8c43fca664b6cb043aa1549d8cfcea5cb1e5f1b (patch)
treeb1e64b65a6c207e7ecd8ae2ca7889ed8befd3782 /app-text
parentnet-libs/dleyna-renderer: update DESCRIPTION (diff)
downloadgentoo-b8c43fca664b6cb043aa1549d8cfcea5cb1e5f1b.tar.gz
gentoo-b8c43fca664b6cb043aa1549d8cfcea5cb1e5f1b.tar.bz2
gentoo-b8c43fca664b6cb043aa1549d8cfcea5cb1e5f1b.zip
app-text/vgrep: bump to v2.5.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/vgrep/Manifest1
-rw-r--r--app-text/vgrep/vgrep-2.5.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-text/vgrep/Manifest b/app-text/vgrep/Manifest
index 392fc95ec721..f8585f5da0fa 100644
--- a/app-text/vgrep/Manifest
+++ b/app-text/vgrep/Manifest
@@ -2,3 +2,4 @@ DIST vgrep-2.3.1.tar.gz 1149421 BLAKE2B c4c9a414bba5e509d57faa9ca6f6ce5cae1dbb00
DIST vgrep-2.3.3.tar.gz 1149769 BLAKE2B 59f15e0f2d9fd069b4926cb26a0517cb1d201dccce53d7c6b3ec1954693a3286396e8d4d72e2c3bcc4bb8e70083ba1ea349dfc4bec244caa112fcc2289063c25 SHA512 b745ec24bb5c329a3d0e4e756e54432f3acf9c24f9492339b69850d5a8e688074323d7e56c584e59f3aedf3a41b84997497791512dae2950424eaed56d6b7329
DIST vgrep-2.4.0.tar.gz 1196159 BLAKE2B f8b6b8166feb17ddeea7978ff14fd729ee395feb9658cbfc838f978f33169c7ca15dcd4008af54582aca25a0803924c508da11603d02e42d1e597a5813f78c3b SHA512 c614b52fe7fa720d3d2bb57830805c1ebb7c47db549aadda9309676b9c286447e693e51f74f969ccd0450934510bfe79c1603717022dd69c9f7f2709cbfd4465
DIST vgrep-2.5.0.tar.gz 1355064 BLAKE2B 7a724fed16ec4589ace159dd5dcbea8e4450393f2c356430d9e8e87b799191b06137e20f2d0c32c53b71ff79d5abaa5551f6254ef6989631d9f6b9d771a5fe18 SHA512 95ee8ff1ca705cec8deaabf8e20d39df23dbac1ab797d025ca253904bcb7f4cbedda3ef052d006064c8d652c06b50cc3e5e532108b23a95511ee7b85b8abb3d4
+DIST vgrep-2.5.1.tar.gz 1355092 BLAKE2B 82b9da137400ede07b3fc2472168139385df8ee639aa0ba34832d20e437ac3da5a86f89fcc9139faa0ca3a037a358a50947b982473d114056483aaf9cfdde52e SHA512 97561ac933fa8a716c9205910d088bf0bb852f2d68ea2226e27e30b5885aabd37223ec4368d72cd0ae5c72735e273004bd054a2b633e61ecb7fd854254cfaecd
diff --git a/app-text/vgrep/vgrep-2.5.1.ebuild b/app-text/vgrep/vgrep-2.5.1.ebuild
new file mode 100644
index 000000000000..6b7efaf86cf6
--- /dev/null
+++ b/app-text/vgrep/vgrep-2.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit go-module
+
+DESCRIPTION="A pager for grep, git-grep and similar grep implementations"
+HOMEPAGE="https://github.com/vrothberg/vgrep"
+SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3+ MIT MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Uses golangci-lint
+RESTRICT="test"
+
+BDEPEND="dev-go/go-md2man"
+
+DOCS=( README.md )
+
+# go binary
+QA_PRESTRIPPED="usr/bin/vgrep"
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ local prefix="${D}/usr"
+ mkdir -p "${prefix}"/bin || die
+
+ emake PREFIX="${prefix}" install
+}