summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-02 12:39:40 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-02 12:39:49 +0200
commitc0c0b6f866a2cffc7203ffb8eca47f8ae44adb17 (patch)
tree5c7534c9b5c02cab558c25bb21d40490a11ba562 /app-text
parentapp-accessibility/orca: Version bump to 43.0 (diff)
downloadgentoo-c0c0b6f866a2cffc7203ffb8eca47f8ae44adb17.tar.gz
gentoo-c0c0b6f866a2cffc7203ffb8eca47f8ae44adb17.tar.bz2
gentoo-c0c0b6f866a2cffc7203ffb8eca47f8ae44adb17.zip
app-text/zotero-bin: add 6.0.15
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-6.0.15.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index a8f646e8913b..ac817f94e66c 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -1,2 +1,4 @@
DIST zotero-bin-6.0.14-amd64.tar.bz2 69149210 BLAKE2B 8979e00f2bb80c97aa65fde5b247198628544202682d1ed754135279c8001658e6aea68bf55ed3051f0e6dd4a27c60f1fe633a4310dc9d53de597048cd937ac3 SHA512 6d3604ed3eb7821316ea378b92bf3bdc3e89e077fa1ccfef7e2baa4d26455f8b04d68aee3036711bf85ef97a79e6f97cc37cb9e1156320b11c6c8fe9156f5526
DIST zotero-bin-6.0.14-x86.tar.bz2 70825827 BLAKE2B e4f2ed26997feac6a3214dd06fc91f5555afd583ce835a4f34bb84c659a38ed2fbdc59692a5fdf2423c7d480d0c7e6b0dbf361a462661bd9fb05955532e15a15 SHA512 3c26ce57570946c2a62eb3631fa95c0130372144ab3d2a5ba795290031f247939d25c541c6f7e9a2f31a3478e09e2196771299bce1683232a476e31836c6bb7a
+DIST zotero-bin-6.0.15-amd64.tar.bz2 69160685 BLAKE2B 0e02bf2762ec89e206bb52c84ce855d00500ba8dc70d8715553eaaf70a9aa97b1b2bd1628dfee24c9c2e47ce7174be2f9b733efce2d9062f93d7f82ec4e12e8c SHA512 f1fb30a3446f9373f9f7aa1d0a21a26dc3f1bf34f0804e2aeabc617cbd2b93b471dfbaec51c41e1745e6813ead9029e5b3c5dae199760193433c51cb7316a8c9
+DIST zotero-bin-6.0.15-x86.tar.bz2 70849558 BLAKE2B 1214ca4b0a06398f5f424a20320cddb7fb8b5f6815f01d05f0d92b274e991df2a6dc5005645fcf64e724229ff346928c44b59364a8de31c80f2f4d65f00a7f66 SHA512 81a994ca2932f423e13988cb3579c2e4d4e2a3aa3a21456fb351259ea8ea4467931bba12f5e5f3416f7bdebc2038dc266fa20f71eea3b62de31d0848ea975d4a
diff --git a/app-text/zotero-bin/zotero-bin-6.0.15.ebuild b/app-text/zotero-bin/zotero-bin-6.0.15.ebuild
new file mode 100644
index 000000000000..a31cabce92e9
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-6.0.15.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="
+ amd64? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}-amd64.tar.bz2 )
+ x86? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-i686&version=${PV} -> ${P}-x86.tar.bz2 )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ dodir opt/zotero
+ cp -a * "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}