summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Chren <dev.rindeal+github.com@gmail.com>2016-04-16 13:46:24 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-19 22:00:33 +0800
commitc59f27ee7d631913a2afd3502b785d6bde76a762 (patch)
treecc15d683ef1b86346d5efb74686f438760315fae /app-text
parentapp-text/cherrytree: add x86 KEYWORD (diff)
downloadgentoo-c59f27ee7d631913a2afd3502b785d6bde76a762.tar.gz
gentoo-c59f27ee7d631913a2afd3502b785d6bde76a762.tar.bz2
gentoo-c59f27ee7d631913a2afd3502b785d6bde76a762.zip
app-text/cherrytree: migrate to distutils-r1.eclass
Closes: https://github.com/gentoo/gentoo/pull/1280 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/cherrytree/cherrytree-0.36.9.ebuild50
1 files changed, 15 insertions, 35 deletions
diff --git a/app-text/cherrytree/cherrytree-0.36.9.ebuild b/app-text/cherrytree/cherrytree-0.36.9.ebuild
index 2c856c0d5f5d..d952e2dba678 100644
--- a/app-text/cherrytree/cherrytree-0.36.9.ebuild
+++ b/app-text/cherrytree/cherrytree-0.36.9.ebuild
@@ -5,8 +5,9 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=true
-inherit fdo-mime eutils python-single-r1
+inherit fdo-mime distutils-r1
DESCRIPTION='A hierarchical note taking application'
HOMEPAGE='http://www.giuspen.com/cherrytree'
@@ -18,7 +19,7 @@ SRC_URI="https://github.com/giuspen/cherrytree/archive/${PV}.tar.gz -> ${P}.tar.
KEYWORDS='~amd64 ~x86'
IUSE='nls'
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
x11-libs/libX11
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pyenchant[${PYTHON_USEDEP}]
@@ -32,44 +33,23 @@ DEPEND="${RDEPEND}
PLOCALES='cs de es fr hy it ja lt nl pl pt_BR ru sl tr uk zh_CN'
inherit l10n
-src_prepare() {
- use nls && l10n_find_plocales_changes 'locale' '' '.po'
-
- sed -i '\|update-desktop-database|d' 'setup.py' || die
+python_prepare_all() {
+ if use nls ; then
+ l10n_find_plocales_changes 'locale' '' '.po'
- default
-}
+ rm_loc() {
+ rm -v -f "locale/${1}.po" || return 1
+ }
+ l10n_for_each_disabled_locale_do rm_loc
+ fi
-src_compile() {
- local args=()
- use nls || args+=( '--without-gettext' )
+ sed -i '\|update-desktop-database|d' 'setup.py' || die
- "${EPYTHON}" ./setup.py "${args[@]}" build
+ distutils-r1_python_prepare_all
}
-src_install() {
- dobin "${PN}"
-
- doicon -s scalable "glade/svg/${PN}.svg"
- domenu "linux/${PN}.desktop"
- doman "linux/${PN}.1"
-
- insinto "/usr/share/${PN}"
- doins -r 'glade/' 'modules/' 'language-specs/'
-
- insinto '/usr/share/mime-info'
- doins "linux/${PN}".{mime,keys}
- insinto '/usr/share/mime/packages'
- doins "linux/${PN}.xml"
-
- if use nls ; then
- ins_loc() {
- # cannot use domo() as it installs files into a wrong dir
- insinto "/usr/share/locale/${1}/LC_MESSAGES"
- doins "build/mo/${1}/${PN}.mo"
- }
- l10n_for_each_locale_do ins_loc
- fi
+src_configure() {
+ use nls || mydistutilsargs+=( '--without-gettext' )
}
pkg_postinst() {