summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Chren <dev.rindeal@gmail.com>2016-06-22 22:52:59 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-07-01 06:57:17 +0000
commitc71d95584a50dcd61b29668aaae69cc23f8bcad7 (patch)
tree37d5bf1a756c6b708926a6742341fb50a5b8f4f9 /app-text
parentapp-text/cherrytree: remove old v0.36.9 (diff)
downloadgentoo-c71d95584a50dcd61b29668aaae69cc23f8bcad7.tar.gz
gentoo-c71d95584a50dcd61b29668aaae69cc23f8bcad7.tar.bz2
gentoo-c71d95584a50dcd61b29668aaae69cc23f8bcad7.zip
app-text/cherrytree: update
- revert 52e5e711414bc5b3e803fbbe45c506c484c29df8 - switch to xdg.eclass Closes: https://github.com/gentoo/gentoo/pull/1722 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/cherrytree/cherrytree-0.37.0.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/app-text/cherrytree/cherrytree-0.37.0.ebuild b/app-text/cherrytree/cherrytree-0.37.0.ebuild
index 3d8fa897cf6b..2b296530f482 100644
--- a/app-text/cherrytree/cherrytree-0.37.0.ebuild
+++ b/app-text/cherrytree/cherrytree-0.37.0.ebuild
@@ -7,7 +7,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=true
-inherit fdo-mime distutils-r1
+inherit xdg distutils-r1
DESCRIPTION='A hierarchical note taking application'
HOMEPAGE='http://www.giuspen.com/cherrytree'
@@ -34,6 +34,8 @@ PLOCALES='cs de es fr hy it ja lt nl pl pt_BR ru sl tr uk zh_CN'
inherit l10n
python_prepare_all() {
+ xdg_src_prepare
+
if use nls ; then
l10n_find_plocales_changes 'locale' '' '.po'
@@ -43,17 +45,11 @@ python_prepare_all() {
l10n_for_each_disabled_locale_do rm_loc
fi
- sed -i '\|update-desktop-database|d' 'setup.py' || die
+ sed -r -e '/\bupdate-desktop-database\b/d' -i -- 'setup.py' || die
distutils-r1_python_prepare_all
}
python_configure_all() {
- use nls || mydistutilsargs+=( '--without-gettext' )
- distutils-r1_python_configure_all
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ use nls || mydistutilsargs+=( --without-gettext )
}