summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-13 18:47:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-13 21:45:02 +0100
commitd08f21f59b6305ab3239ea43cd979edf405b1a83 (patch)
treec05d9443efddbbb8510c75e348b82853e6cea568 /app-text
parentapp-text/libwpd: Fix build with GCC-4.8 (diff)
downloadgentoo-d08f21f59b6305ab3239ea43cd979edf405b1a83.tar.gz
gentoo-d08f21f59b6305ab3239ea43cd979edf405b1a83.tar.bz2
gentoo-d08f21f59b6305ab3239ea43cd979edf405b1a83.zip
app-text/libwpg: 0.3.3 version bump, EAPI-7 bump
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libwpg/Manifest1
-rw-r--r--app-text/libwpg/libwpg-0.3.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-text/libwpg/Manifest b/app-text/libwpg/Manifest
index e4dd11ea4eae..9eaa8bd895dd 100644
--- a/app-text/libwpg/Manifest
+++ b/app-text/libwpg/Manifest
@@ -1 +1,2 @@
DIST libwpg-0.3.2.tar.xz 326840 BLAKE2B a32668671bf0f6a69555dea39a522fac65f7522d7fda5cc29b8d2588fa268f1923e959bb6aa75c6ed1d4c40dde5cf458577098e4662dcee769a449ae36f13229 SHA512 f3f76a17056274b2dfd11ce4eb451411d8458b00b3f7be4fae0a932a382f247adbaae1f4f8f6005e7b84f063e415ef5ab609015ba32f779c6ab2f0404b275f3f
+DIST libwpg-0.3.3.tar.xz 328664 BLAKE2B 02ffaf8ea96e66dea94d847c85e17db5b7efcc5891bb1bf4069e664ece09f808b7462fcbb08a75d6ab17fff4ea51a8e494c48fba1540aed132f47d05b746e1a5 SHA512 99f8346b336eb902626fe07836c73870a57e100620ddd242ce7c2866e564483ed024a3a0b2804f81a0f59a0873310c3a93c005d306437a27818a6f4374c0c491
diff --git a/app-text/libwpg/libwpg-0.3.3.ebuild b/app-text/libwpg/libwpg-0.3.3.ebuild
new file mode 100644
index 000000000000..d21cc0f2a78d
--- /dev/null
+++ b/app-text/libwpg/libwpg-0.3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.10[tools]
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --program-suffix=-${SLOT}
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}