summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-11-20 14:45:01 -0500
committerBrian Evans <grknight@gentoo.org>2015-11-20 14:45:33 -0500
commitd0e5cefb1b09f5abfe531c6523c47f02de9d81d9 (patch)
treeac4ae0bb4bb905b70e9b8b75083fd9823ae7e7f8 /app-text
parentMore masks are needed for selinux vs. systemd issues (diff)
downloadgentoo-d0e5cefb1b09f5abfe531c6523c47f02de9d81d9.tar.gz
gentoo-d0e5cefb1b09f5abfe531c6523c47f02de9d81d9.tar.bz2
gentoo-d0e5cefb1b09f5abfe531c6523c47f02de9d81d9.zip
app-text/groonga: Version bump
Package-Manager: portage-2.2.25
Diffstat (limited to 'app-text')
-rw-r--r--app-text/groonga/Manifest1
-rw-r--r--app-text/groonga/groonga-5.0.9.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/app-text/groonga/Manifest b/app-text/groonga/Manifest
index d2f9b0763790..8d67ca410715 100644
--- a/app-text/groonga/Manifest
+++ b/app-text/groonga/Manifest
@@ -1,2 +1,3 @@
DIST groonga-4.0.7.tar.gz 10990151 SHA256 ec1d19b05c7a592a316e845ff4c5549c6236cc7ea83423c0fc7831c16161bbbf SHA512 942c28205ffb2c7d3ba767ff68b342ef5b7b9fef72131782635e86682c82a4ea3dad9d5263a42563ded22db573015c9859e49dc20c812f7a6534478b22d8b9a8 WHIRLPOOL 2473c14bcc50c87bfb925e73cc3c4cd2c02915ac498a5e40aeee312ac9873857406e38e8146fabe722250f2d258b6444813d4c47726c16ce4cfceea35f207d3a
DIST groonga-5.0.3.tar.gz 12421501 SHA256 d4f3e9d00cb16c0028cb32422fa666cbbfb32f47597988fd308931274d94cf52 SHA512 c4595054f46e150b0b95b3d1fb6a18098c93471ee0cdeefc54d266a710db57d6b68a6aceb1a61ede5ebb4e1b5518be64b9b96809bd85634b61c84c1923cbf158 WHIRLPOOL bbcf91770eb626dfaf5d01e04b6f4b2f4ee6fff8fad73cdca36c500560ce8d0b9dc606391b1ae0a23d2fd763ba4eddbc69f2eb8b692a5c3c59c1b21745d01de0
+DIST groonga-5.0.9.tar.gz 12851324 SHA256 4fb59009dca154ffb53f9b408dc296e6e215f8eda613a8ef184fa634e702d35d SHA512 6e89be8894737616cfcbd0edd92c94a25fb8a2f9c97bd0aab10c2d628664aa328384d6b953516fe96cec5b58fd229c42262caad4785ca9574c759d6d7177fba6 WHIRLPOOL 7f7ac215d4eb0eca0eb18e496a79c6023fe2040f2423c3b4b968d4923b800676c1ad2982880925880ffee5b92ff508b21132ecc2f9b7675612e147adfd13dd6c
diff --git a/app-text/groonga/groonga-5.0.9.ebuild b/app-text/groonga/groonga-5.0.9.ebuild
new file mode 100644
index 000000000000..494462be877a
--- /dev/null
+++ b/app-text/groonga/groonga-5.0.9.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils libtool user
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="abort benchmark debug doc dynamic-malloc-change +exact-alloc-count examples fmalloc futex libedit libevent lzo mecab msgpack +nfkc sphinx static-libs uyield zeromq zlib"
+
+RDEPEND="benchmark? ( >=dev-libs/glib-2.8 )
+ libedit? ( >=dev-libs/libedit-3 )
+ libevent? ( dev-libs/libevent )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ msgpack? ( dev-libs/msgpack )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zeromq? ( net-libs/zeromq )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sphinx? ( dev-python/sphinx )"
+
+REQUIRED_USE=" abort? ( dynamic-malloc-change ) fmalloc? ( dynamic-malloc-change ) sphinx? ( doc )"
+
+pkg_setup() {
+ enewgroup groonga
+ enewuser groonga -1 -1 -1 groonga
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # httpd is a bundled copy of nginx; disabled for security reasons
+ # prce only is used with httpd
+ # kytea and libstemmer are not available in portage
+ # ruby is only used for an http test
+ econf \
+ --disable-groonga-httpd \
+ --without-pcre \
+ --without-kytea \
+ --without-libstemmer \
+ --with-log-path="${EROOT}var/log/${PN}.log" \
+ --docdir="${EROOT}usr/share/doc/${P}" \
+ --without-ruby \
+ $(use_enable abort) \
+ $(use_enable benchmark) \
+ $(use_enable debug memory-debug) \
+ $(use_enable doc document) \
+ $(use_enable dynamic-malloc-change) \
+ $(use_enable exact-alloc-count) \
+ $(use_enable fmalloc) \
+ $(use_enable futex) \
+ $(use_enable libedit) \
+ $(use_with libevent) \
+ $(use_with lzo) \
+ $(use_with mecab) \
+ $(use_with msgpack message-pack "${EROOT}usr") \
+ $(use_enable nfkc) \
+ $(use_with sphinx sphinx-build) \
+ $(use_enable static-libs static) \
+ $(use_enable uyield) \
+ $(use_enable zeromq) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ keepdir /var/{log,lib}/${PN}
+ fowners groonga:groonga /var/{log,lib}/${PN}
+
+ dodoc README.md
+
+ use examples || rm -r "${D}usr/share/${PN}" || die
+ # Extra init script
+ rm -r "${D}usr/sbin/groonga-httpd-restart" || die
+}