summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 22:12:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 22:27:33 +0200
commitdebfbc200e95195e3b67017f48379d1f2a02d390 (patch)
treeee81975bd836061dd020bf13d71a707c8ea4d70f /app-text
parentmedia-libs/libvisio: 0.1.7 version bump (diff)
downloadgentoo-debfbc200e95195e3b67017f48379d1f2a02d390.tar.gz
gentoo-debfbc200e95195e3b67017f48379d1f2a02d390.tar.bz2
gentoo-debfbc200e95195e3b67017f48379d1f2a02d390.zip
app-text/libabw: 0.1.3 version bump, EAPI-7 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libabw/Manifest1
-rw-r--r--app-text/libabw/libabw-0.1.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/libabw/Manifest b/app-text/libabw/Manifest
index 907099d0d309..975bf466f44e 100644
--- a/app-text/libabw/Manifest
+++ b/app-text/libabw/Manifest
@@ -1 +1,2 @@
DIST libabw-0.1.2.tar.xz 318400 BLAKE2B ba25542da0d6568530241892dbdba72d2b0dcf667b50e0c1a4e656e0facf82bf77ca8eff8db4d6e57ab699f12d8dad511d32aee291541ffe6460b2ee98590b68 SHA512 a365c1aa047a97a86eee6bce8463646bdf248a51013139ee288402a832fd545586e072d7c7fc11a56f42e3637de9e922197be20d0587e53c51fd80ced409a6cd
+DIST libabw-0.1.3.tar.xz 318808 BLAKE2B 234ff797bf3798bc7f14f2b3f0d0cc2d80eda2a6ba2d656288c26e58d53b9798003d7f45ad7c9a0f504da36c8c8ba367f8fe5b565a85fbc6a1f1627d89e7e353 SHA512 0d2646e1bad1e11b3da43714ac5931fc67ffdbc4e7a25a44ef5b6e6a41de1e0ae14596b4a87cceb07bf56dbbe9344622b3d60afcb054ee0ab8577ca8e9b5c289
diff --git a/app-text/libabw/libabw-0.1.3.ebuild b/app-text/libabw/libabw-0.1.3.ebuild
new file mode 100644
index 000000000000..bae7f1dcebdb
--- /dev/null
+++ b/app-text/libabw/libabw-0.1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Library parsing abiword documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libabw"
+SRC_URI="https://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ sys-devel/libtool
+"
+
+src_configure() {
+ # bug 619470
+ append-cxxflags -std=c++14
+
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}