summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-19 09:44:11 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-19 09:45:00 +0200
commite2a64abb53db0baf1564254ea52c4b9a544e0aa9 (patch)
tree618111eb44056d1a102ae06416b8187d3f4d70df /app-text
parentdev-python/zxcvbn: Enable py3.11 (diff)
downloadgentoo-e2a64abb53db0baf1564254ea52c4b9a544e0aa9.tar.gz
gentoo-e2a64abb53db0baf1564254ea52c4b9a544e0aa9.tar.bz2
gentoo-e2a64abb53db0baf1564254ea52c4b9a544e0aa9.zip
app-text/zotero-bin: add 6.0.8
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zotero-bin/Manifest1
-rw-r--r--app-text/zotero-bin/zotero-bin-6.0.8.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index 28a67970dbf8..8872a9417dd5 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -1 +1,2 @@
DIST zotero-bin-6.0.7.tar.bz2 68578108 BLAKE2B ba1befc180978104396b059dec098e3cb273b19ddeaf9994588ce761752549a6962b31dc4ffcc749317403512df7686beae399a75c66328d24ba256963efe6bd SHA512 a8e060ef062d64e17e78c30018e227e08662fea6dc9818121401aa6bb3f9245b149bfeb0a90f1d4d13243eb705ca8e184deef1bf76f3db395a23470b7bfe0f1d
+DIST zotero-bin-6.0.8.tar.bz2 68592532 BLAKE2B 2a0cd400d2c2ff03e0cbdecf5730404570d4667cf4076badea5f85a02a3170bcf8e60a13224da852e3264a0293f1c187ed690097907b8e9852fc1bb48e5bca54 SHA512 5b39d2a8aa4d3d973f74cb13a5a0feb961639cf7955b447dfff82517fc86f3ad579a0093b4f33e93c7fa974ae026e21dc0f3a320c9de318873f1d0ca0fec467b
diff --git a/app-text/zotero-bin/zotero-bin-6.0.8.ebuild b/app-text/zotero-bin/zotero-bin-6.0.8.ebuild
new file mode 100644
index 000000000000..b9f2fd5004e0
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-6.0.8.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}.tar.bz2"
+S="${WORKDIR}/Zotero_linux-x86_64"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ dodir opt/zotero
+ cp -a "${S}"/* "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}