summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-03-28 18:59:55 +0200
committerSebastian Pipping <sping@gentoo.org>2018-03-28 19:00:27 +0200
commitf37094f6d106aadc1a9bdbeea17600b7f7ad2c9d (patch)
tree4e9f81a3732cebfedc2c8bb630b0f320fa8eb72a /app-text
parentsys-apps/xinetd: depend on libtirpc unconditionally on Linux (diff)
downloadgentoo-f37094f6d106aadc1a9bdbeea17600b7f7ad2c9d.tar.gz
gentoo-f37094f6d106aadc1a9bdbeea17600b7f7ad2c9d.tar.bz2
gentoo-f37094f6d106aadc1a9bdbeea17600b7f7ad2c9d.zip
app-text/dvisvgm: 2.3.5
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-2.3.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index 72bebea37ab1..2ec11cea6d87 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -2,3 +2,4 @@ DIST dvisvgm-1.10.tar.gz 831654 BLAKE2B 7da1032f2450cec4c166b622f488859069052a57
DIST dvisvgm-2.1.3.tar.gz 2802278 BLAKE2B 36e523d4b82a71f26ebc50428c56863a3729d1cf79c63660a5a3cecdd7c55c27e7ad811121e8a2ccdaa37f1ec2fb345d1d5d4f7b59011be7877500df5dba1f48 SHA512 dfd6e94b28dcdf2d1be236f3f29eaf4e3e5b7bb34544cdd55ae09de612b02561dd782b693a9a94eea07420c795d31ef210eba34cb663d7de98f438c089369ff2
DIST dvisvgm-2.3.3.tar.gz 2805568 BLAKE2B 9823d2a8d3b736dfbbfbe0e5d51fb20bf61b4a8d236cc24fadd6e8a918f8f8305dedc23f6d7146574f9302a006a50e33621d350425e1b3c65d780d1354e7b239 SHA512 1b170b5979049f30aaaa5a85d8b5555e87a7af987298980d25c77aebd95b6be56a8518986b8a6eb2215b6dbd32dfbdfdcecb0c81f9d5ffa856370da1b324ed18
DIST dvisvgm-2.3.4.tar.gz 2896641 BLAKE2B af434a418b5ebbb9acaccc4626b6278f3d0c76e4434b9ccec8a0454a109481527bc0a7ac3b242a64a68ca1d71233778d3a90b4c03946db9f1e94c625109f598c SHA512 53c1820dee70f8a017a950400538aa2fe111b762d2f7d3bdb6b8be17de6603395d6e083b73292e688241e6e3adccaaaa2f9d82d5fec7818c2f5779ff28914dd9
+DIST dvisvgm-2.3.5.tar.gz 2897194 BLAKE2B 7661d6f5ac097a6dc62cf873dee84ec47b55e4a87ec07597170d309ac4d8d06fa19e0e14dab3a6273f022c71112a00af4c0bf167e37687037f0c23d1ea74f20b SHA512 fcfbb8e53233383a61c0662951dc914d157eb64c89eb30f54afc36069d3ca6a347dae7e64febafee1ba9ea8d90b278da9cbe36b70169df48f12c42c077cd1038
diff --git a/app-text/dvisvgm/dvisvgm-2.3.5.ebuild b/app-text/dvisvgm/dvisvgm-2.3.5.ebuild
new file mode 100644
index 000000000000..e2eec8fc99a8
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-2.3.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="http://dvisvgm.bplaced.net/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+# Tests don't work from $WORKDIR: kpathsea tries to search in relative
+# directories from where the binary is executed.
+# We cannot really use absolute paths in the kpathsea configuration since that
+# would make it harder for prefix installs.
+RESTRICT="test"
+
+# TODO unbundle app-arch/brotli
+RDEPEND="virtual/tex-base
+ app-text/ghostscript-gpl
+ dev-libs/kpathsea:=
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ dev-libs/kpathsea
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-text/xmlto
+ app-text/asciidoc
+ dev-libs/libxslt
+ virtual/pkgconfig
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local myargs=(
+ --without-ttfautohint
+ )
+ econf "${myargs[@]}"
+}