summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-25 09:41:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-25 09:41:43 +0200
commitfc1c3a5e8911917b04b05c8e10c47c14bcacd5cd (patch)
tree387683efeb28bd4e8cbd4df072f8bd036ba0016b /app-text
parentkde-plasma/kwallet-pam: Remove 5.5.5 (diff)
downloadgentoo-fc1c3a5e8911917b04b05c8e10c47c14bcacd5cd.tar.gz
gentoo-fc1c3a5e8911917b04b05c8e10c47c14bcacd5cd.tar.bz2
gentoo-fc1c3a5e8911917b04b05c8e10c47c14bcacd5cd.zip
app-text/dos2unix: Bump to version 7.3.4
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dos2unix/Manifest1
-rw-r--r--app-text/dos2unix/dos2unix-7.3.4.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-text/dos2unix/Manifest b/app-text/dos2unix/Manifest
index 905e4db849de..e31c49e72d10 100644
--- a/app-text/dos2unix/Manifest
+++ b/app-text/dos2unix/Manifest
@@ -1,3 +1,4 @@
DIST dos2unix-7.3.2.tar.gz 601642 SHA256 c7e8ee0bb3e001cc25a4a908d9a81ac52d124133d6a524a59f995bc90d438689 SHA512 3d042e720c9854ae42ef72d1acf78ff8ff1cbf3c259d2c8bdba0a0b9cbf754fbe2dee9994cb9513cf1df24f26a857a13e828f0c88dc2e50f91e1c33a122eb385 WHIRLPOOL 48652bae9b247f68d9d246ad6e1c9758c04f61de3816126b89bd928bb1e50435b384d05c63a070b851d02657c698d7fbb6de61c1998a9b3d8ed32e0a3354e7ab
DIST dos2unix-7.3.3.tar.gz 638368 SHA256 5c910aea2eae96663c67e87627998c4fe3cded403be5819b4c190e56c82ff0fb SHA512 52218ea17cc63a4b41e1bd12f200dda31e2be65167ca9c913391640c118d7122348aa2e5aec934ee17c8ea77a04cb89a1a572865645a77f6875207295c10e7af WHIRLPOOL 749cabc6d2d57caccf183082689a0d677d7d5b7822c8a92a85a5b2d722284542c95dcd46947ea05a1d2cff1d230351cacf1f0667957f18c7c02c12c6c62f2e16
+DIST dos2unix-7.3.4.tar.gz 640991 SHA256 8ccda7bbc5a2f903dafd95900abb5bf5e77a769b572ef25150fde4056c5f30c5 SHA512 29958a2c702acc112b10f3fcb43fbff3b860c6d1f725c153af9a52dc20736755604f77bec37299dc88923a9e9b2ad73b994e9bc6f42f2757fe1819dd9873d710 WHIRLPOOL 46c771c63572d0d0301db5bde4734297df037654cbc71e5a8f93003fbf503399ec5026bc53fea3b3b10e346e2b59d24bdcd6d9139342354cdb1b8a6e240deaeb
DIST dos2unix-7.3.tar.gz 497218 SHA256 8175f7552a72edaaa8918fdee68ce2cbc982dc25452f33d4dc611d769f4944d1 SHA512 dc70fc4cf12811794e9b33db7cc44085788450104f7beefacea5ac11af5ca76d909235232be51eb7a32ed5d75a01a86a4c6b064060b945c8a7e7968caeb51cea WHIRLPOOL 55b3990816a122c4bc2219b1f89b5d7f619901693b57349b58222166f5c3e006db08a55a26ce62493009459b9a3c6a091a07ecacabf9450a0a7475fbd9f195ae
diff --git a/app-text/dos2unix/dos2unix-7.3.4.ebuild b/app-text/dos2unix/dos2unix-7.3.4.ebuild
new file mode 100644
index 000000000000..5d49f876df10
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-7.3.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PLOCALES="da de eo es fr hu ja nb nl pl pt_BR ru sr sv uk vi zh_CN zh_TW"
+
+inherit l10n toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls test"
+
+RDEPEND="
+ !app-text/hd2u
+ virtual/libintl"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( virtual/perl-Test-Simple )
+ dev-lang/perl"
+
+handle_locales() {
+ # Make sure locale list is kept up-to-date.
+ local detected sorted
+ detected=$(echo $(printf '%s\n' */*.po | sed -e 's:.*/::' -e 's:.po$::' | sort -u))
+ sorted=$(echo $(printf '%s\n' ${PLOCALES} | sort -u))
+ if [[ ${sorted} != "${detected}" ]] ; then
+ eerror "The ebuild needs to be kept in sync."
+ eerror "PLOCALES: ${sorted}"
+ eerror "po*/*.po: ${detected}"
+ die "sync PLOCALES"
+ fi
+
+ # Deal with selective install of locales.
+ rm_loc() { rm po*/$1.po || die; }
+ l10n_for_each_disabled_locale_do rm_loc
+}
+
+src_prepare() {
+ default
+
+ handle_locales
+
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}