summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-07-19 12:01:02 +0200
committerJeroen Roovers <jer@gentoo.org>2020-07-19 12:15:22 +0200
commitff737ce55c53975710105c1c4b2b11097e38ca8b (patch)
tree8b090269cc03794b42f6daff76fddf8b16d3fa3b /app-text
parentnet-analyzer/zabbix: removed obsolete (diff)
downloadgentoo-ff737ce55c53975710105c1c4b2b11097e38ca8b.tar.gz
gentoo-ff737ce55c53975710105c1c4b2b11097e38ca8b.tar.bz2
gentoo-ff737ce55c53975710105c1c4b2b11097e38ca8b.zip
app-text/jo: Version 1.4
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/jo/Manifest1
-rw-r--r--app-text/jo/jo-1.4.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-text/jo/Manifest b/app-text/jo/Manifest
index d436b1cedeaf..9fe47d8696cd 100644
--- a/app-text/jo/Manifest
+++ b/app-text/jo/Manifest
@@ -1,2 +1,3 @@
DIST jo-1.1.tar.gz 50395 BLAKE2B 753e65e5b483cee357bcfc1fb95d93fae008acc8a1eeee75e6e68da6d0ed8c9636cd489278c466ffbd179ceaec7121b4fe3f64fe2e9bf70b81febbe15144c0f2 SHA512 fd220acf53d554cb9e9920510dba2f4a01337b126dca89882e02ba96cdd84bf7a5e935a4c06dddb5200cd808f0609fd697e51a56161dc99b1638e33181494242
DIST jo-1.3.tar.gz 143425 BLAKE2B 32efaa84f64b0d3e82173a5121a30e13ce7fed991ec09f26400c90071e5e3cc5cc8af372550f4d9769cc338e852bf50497782c11ffd7d32a52d5769370742fbf SHA512 3c9480257d0ab9d9f19f1aaeb3a5b72e69caff6dcf87118bea8aca74a3b0864c0d17ed52bfc5550783c4636ee3a6acb8578f08316d976cea4f06af7096c12f02
+DIST jo-1.4.tar.gz 144596 BLAKE2B 0e0a0290d276b18fbfea0c770e134f29ea3f1eea9c7e5ccdd6c7d853dc0a8c70279fa464731f5b231d6d9d48816be4e5a6d93c7abc0e03408a86f0e1691d67a0 SHA512 c283b25e76fa06842c4f7d8ae8d94b207981d92a1bd4a064631e0646bdeedc06c1a00dddac405a455b27bda5eb34aaa7dc6d886ccf750741fd4d7312f692d169
diff --git a/app-text/jo/jo-1.4.ebuild b/app-text/jo/jo-1.4.ebuild
new file mode 100644
index 000000000000..bf84777ca6d8
--- /dev/null
+++ b/app-text/jo/jo-1.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1
+
+DESCRIPTION="JSON output from a shell"
+HOMEPAGE="https://github.com/jpmens/jo"
+SRC_URI="https://github.com/jpmens/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ export bashcompdir=$(get_bashcompdir)
+ default
+}
+
+src_install() {
+ default
+ mv "${D}"$(get_bashcompdir)/jo{.bash,} || die
+}