summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-03-06 12:31:03 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-03-06 12:33:58 +0100
commit8fa9c240f0d868b7665c6287fec9c98a00a79361 (patch)
treefda37d360f81f449be6455addae361e624d6e1c4 /app-vim/alternate
parentdev-libs/jansson: Bump to version 2.10 (diff)
downloadgentoo-8fa9c240f0d868b7665c6287fec9c98a00a79361.tar.gz
gentoo-8fa9c240f0d868b7665c6287fec9c98a00a79361.tar.bz2
gentoo-8fa9c240f0d868b7665c6287fec9c98a00a79361.zip
app-vim/alternate: install documentation.
Gentoo-Bug: https://bugs.gentoo.org/483552 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-vim/alternate')
-rw-r--r--app-vim/alternate/Manifest1
-rw-r--r--app-vim/alternate/alternate-2.18-r2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-vim/alternate/Manifest b/app-vim/alternate/Manifest
index abb5770c1893..a745ca0763b9 100644
--- a/app-vim/alternate/Manifest
+++ b/app-vim/alternate/Manifest
@@ -1 +1,2 @@
DIST alternate-2.18.tar.bz2 7907 SHA256 2367638f93c6ce3681a6ad6d5c83f586cd6598abd9f0b20bf02c740ac0efb59e SHA512 397d39a5c5fd186f32f3e0a1651f9b9f739899ffcfdd344e85117c4bb676d8fb8c668410754fefe8934ff1a57537387d49d115dfa17bdca896e423935840ae3f WHIRLPOOL d7635d1812b311232fcbee42d94ad9a0b86176f789d5f9336eb40d2efe5c1a2f660008b8facf5dbba8c094946a574e6b379dd7262dea4aff278c34b7cbe25ec7
+DIST alternate.txt 8897 SHA256 a8fb8daabeee00b7a5c22b65f76dc0758b3e5fcfb95297235ec3ce102bdc4eb3 SHA512 92b24aef5fe1fb459b4cb85ca780ae20126bc79138ac15dec652c15a89b688d40bedc00bdae8fce912c8805b24b8805e45ddbd9e6b1ec10c20e61eed11d37651 WHIRLPOOL 780ae8514b65158a4872821f6847d0186d0ccfdd8b2b232617926aa2d907fb59a7d55abfceac96118565799cf6fc14b4def15ba32c1017126f4ff9f948ae3882
diff --git a/app-vim/alternate/alternate-2.18-r2.ebuild b/app-vim/alternate/alternate-2.18-r2.ebuild
new file mode 100644
index 000000000000..53430a53691f
--- /dev/null
+++ b/app-vim/alternate/alternate-2.18-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: quickly switch between .c and .h files"
+HOMEPAGE="https://github.com/vim-scripts/a.vim"
+SRC_URI="
+ https://github.com/vim-scripts/a.vim/archive/${PV}.tar.bz2 -> ${P}.tar.bz2
+ http://www.vim.org/scripts/download_script.php?src_id=6347 -> ${PN}.txt
+"
+
+LICENSE="alternate"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a new :A command which will switch between a .c
+file and the associated .h file. There is also :AS to split windows and
+:AV to split windows vertiically."
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hh-cc-alternation.patch
+)
+
+src_prepare() {
+ default
+ mkdir -p "${S}/doc" || die
+ cp "${DISTDIR}/${PN}.txt" "${S}/doc" || die
+}