summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-17 10:55:30 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-18 07:52:03 +0200
commit62ff1bc276577517184ac5c15b8f2d8ce5a4ee97 (patch)
tree9208fab77ad7119ef7f7b5369da969112065b2cf /app-vim/command-t
parentdev-ruby/amq-client: cleanup (diff)
downloadgentoo-62ff1bc276577517184ac5c15b8f2d8ce5a4ee97.tar.gz
gentoo-62ff1bc276577517184ac5c15b8f2d8ce5a4ee97.tar.bz2
gentoo-62ff1bc276577517184ac5c15b8f2d8ce5a4ee97.zip
app-vim/command-t: cleanup
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-vim/command-t')
-rw-r--r--app-vim/command-t/command-t-5.0.3.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/app-vim/command-t/command-t-5.0.3.ebuild b/app-vim/command-t/command-t-5.0.3.ebuild
deleted file mode 100644
index 0783b39f1266..000000000000
--- a/app-vim/command-t/command-t-5.0.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-inherit vim-plugin ruby-ng
-
-DESCRIPTION="vim plugin: fast file navigation for vim"
-HOMEPAGE="https://vim.sourceforge.io/scripts/script.php?script_id=3025 https://github.com/wincent/command-t"
-SRC_URI="https://github.com/wincent/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~x86"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
-
-all_ruby_prepare() {
- find "${S}" -name .gitignore -delete || die
-}
-
-each_ruby_configure() {
- cd ruby/${PN}/ext/${PN} || die
- ${RUBY} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- cd ruby/${PN}/ext/${PN} || die
- emake V=1
- rm *.o *.c *.h *.log extconf.rb depend Makefile || die
-}
-
-each_ruby_install() {
- local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
- insinto "${sitelibdir}"
- doins -r ruby/${PN}/{ext,lib}/*
-}
-
-all_ruby_install() {
- rm -r appstream bin fixtures data ruby/${PN}/{ext,lib,*.gemspec} spec vendor || die
-
- vim-plugin_src_install
-
- # make sure scripts are executable
- chmod +x "${ED}"/usr/share/vim/vimfiles/ruby/${PN}/bin/* || die
-}