summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/conque
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/conque')
-rw-r--r--app-vim/conque/Manifest1
-rw-r--r--app-vim/conque/conque-2.3-r1.ebuild26
-rw-r--r--app-vim/conque/conque-2.3.ebuild23
-rw-r--r--app-vim/conque/metadata.xml8
4 files changed, 58 insertions, 0 deletions
diff --git a/app-vim/conque/Manifest b/app-vim/conque/Manifest
new file mode 100644
index 000000000000..c5cc7b07fceb
--- /dev/null
+++ b/app-vim/conque/Manifest
@@ -0,0 +1 @@
+DIST conque_2.3.tar.gz 52195 SHA256 cf00f05e73c4296462cc1219142a5d1c9a371e93a1c7eba3a672caeff02f55b9 SHA512 b69c0564ccaf897ee2f18d0769877986e67006cf33dbefe2bbc85261726372f09669d19aa118de58ccfb847cc8b7e670e25c030128eec665e1cecf0a96cb4b89 WHIRLPOOL 5bb507012bf02bf189bf59ff11ba51df5df4e33d922f1cdd663a1ea14b8cd80f9f3a20c1ac98b985bf42070ff1059d7e9ea6d17dd2349ffb7ce45ca22f9732fa
diff --git a/app-vim/conque/conque-2.3-r1.ebuild b/app-vim/conque/conque-2.3-r1.ebuild
new file mode 100644
index 000000000000..87617f253aea
--- /dev/null
+++ b/app-vim/conque/conque-2.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+VIM_PLUGIN_VIM_VERSION="7.1"
+
+inherit python-single-r1 vim-plugin
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="vim plugin: Run interactive commands inside a Vim buffer"
+HOMEPAGE="http://code.google.com/p/conque/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="ConqueTerm"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/app-vim/conque/conque-2.3.ebuild b/app-vim/conque/conque-2.3.ebuild
new file mode 100644
index 000000000000..0383945d7427
--- /dev/null
+++ b/app-vim/conque/conque-2.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+VIM_PLUGIN_VIM_VERSION="7.1"
+
+inherit vim-plugin
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="vim plugin: Run interactive commands inside a Vim buffer"
+HOMEPAGE="http://code.google.com/p/conque/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ >=dev-lang/python-2.3"
+
+VIM_PLUGIN_HELPFILES="ConqueTerm"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/app-vim/conque/metadata.xml b/app-vim/conque/metadata.xml
new file mode 100644
index 000000000000..b00e0178977a
--- /dev/null
+++ b/app-vim/conque/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="google-code">conque</remote-id>
+ </upstream>
+</pkgmetadata>