summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-08-08 14:09:33 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-11-15 16:03:22 +0100
commit92733b24f57c867222d4f49de0b1cb67a75919d5 (patch)
treeab68692c6c86bca57a8c7ddc61aa822c7eb64995 /app-vim/csound-syntax
parentdev-libs/dqlite: Mark ~arm64 (diff)
downloadgentoo-92733b24f57c867222d4f49de0b1cb67a75919d5.tar.gz
gentoo-92733b24f57c867222d4f49de0b1cb67a75919d5.tar.bz2
gentoo-92733b24f57c867222d4f49de0b1cb67a75919d5.zip
app-vim/csound-syntax: version bump to 0.8.1.
Closes: https://bugs.gentoo.org/736358 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/17051 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim/csound-syntax')
-rw-r--r--app-vim/csound-syntax/Manifest1
-rw-r--r--app-vim/csound-syntax/csound-syntax-0.8.1.ebuild24
-rw-r--r--app-vim/csound-syntax/csound-syntax-20160804.ebuild2
-rw-r--r--app-vim/csound-syntax/files/csound-syntax-doc.patch (renamed from app-vim/csound-syntax/files/csound-syntax-20160804-doc.patch)0
4 files changed, 26 insertions, 1 deletions
diff --git a/app-vim/csound-syntax/Manifest b/app-vim/csound-syntax/Manifest
index 13e5c0d5e4bf..782d85f0c0c8 100644
--- a/app-vim/csound-syntax/Manifest
+++ b/app-vim/csound-syntax/Manifest
@@ -1 +1,2 @@
+DIST csound-syntax-0.8.1.tar.gz 404555 BLAKE2B a26d158a3a050b3767cade77a0ccb8f12491a4b9e6957c6c8ccf1de5402367f58ddf9c367f314c0410346de08ddde49964cc4c5e38f6bc7605a4965f28afcedd SHA512 a87458efabcef4e3681b8f6b6325ad1fbe5b68befbf602fe858db2baf455c66c3a5b953a6aeeb28155867f7c53ae29618801c6b66a30118346069a1598b5ada1
DIST csound-syntax-20160804.tar.bz2 326658 BLAKE2B 04ba7e1eb3afee6b32de4603e91f78fdc7fd3b70b137bd05ecac5ace2b34222a1cc8c095cd7776abe46b7bb18bd67d1711bca75f20e2f656162d414f2c6e2b2f SHA512 83ba89768be3d9e5dd701cc8323fbbff75ce399210891fc1e5676e278c39cfdb4b5e4a354c93c1f439a667d0ea65f459aea0b6f79740a061381e22d2557c0eb8
diff --git a/app-vim/csound-syntax/csound-syntax-0.8.1.ebuild b/app-vim/csound-syntax/csound-syntax-0.8.1.ebuild
new file mode 100644
index 000000000000..a2e3cf0246cc
--- /dev/null
+++ b/app-vim/csound-syntax/csound-syntax-0.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+MY_P="csound-vim-${PV}"
+
+DESCRIPTION="vim plugin: set of tools for editing Csound files with vim"
+HOMEPAGE="https://github.com/luisjure/csound"
+SRC_URI="https://github.com/luisjure/csound-vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-doc.patch" )
+
+src_prepare() {
+ rm -v LICENSE README.md || die
+ default
+}
diff --git a/app-vim/csound-syntax/csound-syntax-20160804.ebuild b/app-vim/csound-syntax/csound-syntax-20160804.ebuild
index 1562317fb7f5..f562b9ebe09c 100644
--- a/app-vim/csound-syntax/csound-syntax-20160804.ebuild
+++ b/app-vim/csound-syntax/csound-syntax-20160804.ebuild
@@ -12,7 +12,7 @@ KEYWORDS="amd64 x86"
VIM_PLUGIN_HELPFILES="${PN}"
-PATCHES=( "${FILESDIR}/${P}-doc.patch" )
+PATCHES=( "${FILESDIR}/${PN}-doc.patch" )
src_prepare() {
rm -v LICENSE README.md || die
diff --git a/app-vim/csound-syntax/files/csound-syntax-20160804-doc.patch b/app-vim/csound-syntax/files/csound-syntax-doc.patch
index c2cc7eccbad1..c2cc7eccbad1 100644
--- a/app-vim/csound-syntax/files/csound-syntax-20160804-doc.patch
+++ b/app-vim/csound-syntax/files/csound-syntax-doc.patch