summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-10-07 14:11:29 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-10-07 14:11:29 -0700
commit9a59deaacdd7c0754d5bebbc72425e30976c4394 (patch)
treee61c4d2023f5dd51e562246c3d34c5878eea529b /app-vim/fugitive
parentdev-perl/YAML: Version bump 1.30 (diff)
downloadgentoo-9a59deaacdd7c0754d5bebbc72425e30976c4394.tar.gz
gentoo-9a59deaacdd7c0754d5bebbc72425e30976c4394.tar.bz2
gentoo-9a59deaacdd7c0754d5bebbc72425e30976c4394.zip
app-vim/fugitive-3.4: Version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-vim/fugitive')
-rw-r--r--app-vim/fugitive/Manifest1
-rw-r--r--app-vim/fugitive/fugitive-3.4.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
index 17f21efd3a75..dce65e5f2d1d 100644
--- a/app-vim/fugitive/Manifest
+++ b/app-vim/fugitive/Manifest
@@ -2,3 +2,4 @@ DIST fugitive-2.4.tar.gz 33340 BLAKE2B d5e5df47e0492510abae735dd47b51d797fe38862
DIST fugitive-2.5.tar.gz 39318 BLAKE2B 437f4c36b357937fc83e0107882d535c5cc9e609801147d1a48c28e16c4f964c221ff404301e57c9d740a04caf4cf5383a1f307ad89a76294e13b784561223bd SHA512 9a58ff3fa9eae72fca3d1232d01856ef56fe38b7bbf61be44ec4cdf4f0f69fca69fafe19266d657530a6d08f856236b1d1370bb770b14402bb7e476d5ca4bb78
DIST fugitive-3.1.tar.gz 61142 BLAKE2B 15436725924d7ab09903973d77e9d7ce904f6bfaee451da2d3240236b2ef0589efd4b34e3673550749a6f021802018b2fb86f09ecdd727231f58bce3fd7c82b0 SHA512 4301e53a688ef1c822c146e04c41b6724cc38503733c622c0be8ea67ff2dd442f487fab8569bd3c8f7d97f6a4d5b42b58c0f23a216d74b862c09ed5c57f6ea87
DIST fugitive-3.2.tar.gz 64708 BLAKE2B cab484ec66b7c54857856ed1f6cbebbf6d3fb1afdb35b004f72f8c06785a18d8810244255305cd949e25d1f78d734c46e400488526631b4070d3e0b104830552 SHA512 c7ac97d52f683a73545efddf33986dedecbae25208ebf0703dccf99cb46fd5020362f724c5b530aeca40467d9e864ce6597d6eb5eaa93a33643191e1aa5b44db
+DIST fugitive-3.4.tar.gz 80677 BLAKE2B 7cb341851248eb05a8094617f349e382cb8704f69116d8a00f07db40d96b4cc86b98515a59c489116fe7fdadb9a73a65819bf792005bda316f1a0bca311e6938 SHA512 313f1b06c843f85cfdbee059f1470b1ed062c2055e552fa1e05b01e59d9950c181b19e7553cbbca575b1951949970691081582128be7148885485d4fbed0a4d2
diff --git a/app-vim/fugitive/fugitive-3.4.ebuild b/app-vim/fugitive/fugitive-3.4.ebuild
new file mode 100644
index 000000000000..468c05838b33
--- /dev/null
+++ b/app-vim/fugitive/fugitive-3.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"