summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-14 16:17:46 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-14 16:23:18 +0200
commit32bd21420b7ddc70ed91684db8003986b7e6cf17 (patch)
tree3b0b52551753612e35f455d70aa7db72ee38d2d2 /app-vim/gentoo-syntax
parentapp-vim/gentoo-syntax: Use git.g.o as primary git source (diff)
downloadgentoo-32bd21420b7ddc70ed91684db8003986b7e6cf17.tar.gz
gentoo-32bd21420b7ddc70ed91684db8003986b7e6cf17.tar.bz2
gentoo-32bd21420b7ddc70ed91684db8003986b7e6cf17.zip
app-vim/gentoo-syntax: Bump to 20180814 snapshot
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20180814.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 6d084d0ff724..56b96c9e98f1 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-syntax-20160530.tar.gz 18950 BLAKE2B 0e769cb4d67ebf1b4299a1aa0dc1bc1ce942a9e6b4f3528b5499ff83ffe9d165697576901c5ba9cca52de6e26abd0298f1f7a5383cdc0c8ca1dff0de2945080c SHA512 38881c5f16499eb053eb7a5514f6324b2a161f1392a044db0bbaf0cb71a0f17e1edebd4a685ff856a78525fbcb8c6267daa2503cfbc6f94d841cf3f6a25045bd
DIST gentoo-syntax-20170225.tar.gz 18939 BLAKE2B 7586b45791e74e69ad6e0607bc0a4d52eba4747a6c4d9933d43db1196ceb57ac6317279c9e86f77c71bdb7379828dd96fe6d63a2933a3660f1639faf1b6df5d5 SHA512 2c01577910eccd413b85c094dbd12bf8445e2f560be1fffc4a4c3130b32587f9c298d8442b5cf12bd7d2950ab8c9e5b95a72f2f41c42c6dc939ffa2c26fd71d5
+DIST gentoo-syntax-20180814.tar.bz2 18337 BLAKE2B e2808ff4bab17378ac9a15270f32edb67c0a8f4a7e17757d9c128e186fe31add967c169aa9e62fd5fc95dfbadeab72e37c34a14a5452b80c0a1ceafd8bdec85a SHA512 a524a324e3bb1656b2dba9333e03bd130d3700791782d98fed57ea6065f398e4ad29f7980ad823940a44cd1f9f58244b8a908ef4aa3c82c0f7c46882005f358e
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20180814.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20180814.ebuild
new file mode 100644
index 000000000000..badfc293470c
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20180814.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}