summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerenc Erki <erkiferenc@gmail.com>2017-10-29 23:25:15 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-10 00:13:17 +0100
commit2f0dc74cee7050f7bb6b604255f3f389fa758713 (patch)
treea82d60c6a213598d3e00ce80ef80f277d5482501 /app-vim/perl-support/perl-support-5.4.ebuild
parentapp-vim/molokai: new ebuild. (diff)
downloadgentoo-2f0dc74cee7050f7bb6b604255f3f389fa758713.tar.gz
gentoo-2f0dc74cee7050f7bb6b604255f3f389fa758713.tar.bz2
gentoo-2f0dc74cee7050f7bb6b604255f3f389fa758713.zip
app-vim/perl-support: version bump to 5.4.
Closes: https://bugs.gentoo.org/613928 Closes: https://github.com/gentoo/gentoo/pull/6078 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-vim/perl-support/perl-support-5.4.ebuild')
-rw-r--r--app-vim/perl-support/perl-support-5.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/perl-support/perl-support-5.4.ebuild b/app-vim/perl-support/perl-support-5.4.ebuild
new file mode 100644
index 000000000000..80a42f4e20a7
--- /dev/null
+++ b/app-vim/perl-support/perl-support-5.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Perl-IDE - Write and run Perl scripts using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=556"
+SRC_URI="https://github.com/WolfgangMehner/perl-support/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2 GPL-2+"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+VIM_PLUGIN_HELPFILES="perlsupport.txt"
+
+RDEPEND="
+ dev-perl/Perl-Tags
+ dev-perl/Perl-Critic"
+
+S="${WORKDIR}/${PN}-version-${PV}"
+
+src_prepare() {
+ # Don't set tabstop and shiftwidth
+ sed -i '/=4/s/^/"/' ftplugin/perl.vim || die
+}
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,perl-hot-keys.pdf}
+ rm -r ${PN}/doc/ || die
+
+ vim-plugin_src_install
+}