summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/recover
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/recover')
-rw-r--r--app-vim/recover/Manifest1
-rw-r--r--app-vim/recover/metadata.xml8
-rw-r--r--app-vim/recover/recover-0.18.ebuild13
3 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/recover/Manifest b/app-vim/recover/Manifest
new file mode 100644
index 000000000000..c097647ff158
--- /dev/null
+++ b/app-vim/recover/Manifest
@@ -0,0 +1 @@
+DIST recover-0.18.tar.bz2 8137 SHA256 9fcd1d440ef0709b4c9719c758d67ba349970b08027b16341290170a4b27cde4 SHA512 fe31626bd9bfacf299536f4943b65d61262da8bfec9c83b085e67a52833d8fe8c5ecc81fade50c451cfe2889e0cfa938401635a2c9471ebd31191fc1c7beeb71 WHIRLPOOL e1d159a1c182f514a625c9dceadb6ecba6f2a9b9b9f335654cdc53ef4758bb9922a46a441ac8079590d1ba1196548c5a275f31d8ff580510616c5d93e9160f35
diff --git a/app-vim/recover/metadata.xml b/app-vim/recover/metadata.xml
new file mode 100644
index 000000000000..4fc7250111cd
--- /dev/null
+++ b/app-vim/recover/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">chrisbra/Recover.vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/recover/recover-0.18.ebuild b/app-vim/recover/recover-0.18.ebuild
new file mode 100644
index 000000000000..8d3382641fdd
--- /dev/null
+++ b/app-vim/recover/recover-0.18.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: show differences for recovered files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3068 https://github.com/chrisbra/Recover.vim"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"