summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-21 17:19:57 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-21 18:04:47 +0200
commit4f847001ccb1b9cc30fde809fe37ca6cdf053a5f (patch)
treeaa7055089bb5ed54c244348cd2b241c21207f18e /app-vim/vim-latex
parentsci-chemistry/votca-xtp: version bump (diff)
downloadgentoo-4f847001ccb1b9cc30fde809fe37ca6cdf053a5f.tar.gz
gentoo-4f847001ccb1b9cc30fde809fe37ca6cdf053a5f.tar.bz2
gentoo-4f847001ccb1b9cc30fde809fe37ca6cdf053a5f.zip
app-vim/vim-latex: add python{3_7,3_8} targets.
Closes: https://bugs.gentoo.org/721558 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim/vim-latex')
-rw-r--r--app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild b/app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild
new file mode 100644
index 000000000000..ed03b0f51f16
--- /dev/null
+++ b/app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+ virtual/latex-base
+ !app-vim/vimtex"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_compile() { :; }
+
+src_install() {
+ # remove unused metadata
+ rm vim-latex.metainfo.xml || die
+
+ # don't mess up vim's doc dir with random files
+ mv doc mydoc || die
+ mkdir doc || die
+ mv mydoc/*.txt doc/ || die
+ rm -rf mydoc || die
+
+ # don't install buggy tags scripts, use ctags instead
+ rm latextags ltags || die
+
+ vim-plugin_src_install
+
+ # use executable permissions (bug #352403)
+ fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ echo
+ elog "To use the vim-latex plugin add:"
+ elog " filetype plugin on"
+ elog ' set grepprg=grep\ -nH\ $*'
+ elog " let g:tex_flavor='latex'"
+ elog "to your ~/.vimrc-file"
+ echo
+ fi
+}