summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-03-07 05:57:53 -0500
committerTim Harder <radhermit@gentoo.org>2017-03-07 05:59:54 -0500
commitf1a7597c991331106308faecb7905191bfdf41d6 (patch)
tree1b48f9e0a059240e6a293317f6b2440765563b01 /app-vim/vimagit/vimagit-9999.ebuild
parentmail-client/kube: add missing dependencies (diff)
downloadgentoo-f1a7597c991331106308faecb7905191bfdf41d6.tar.gz
gentoo-f1a7597c991331106308faecb7905191bfdf41d6.tar.bz2
gentoo-f1a7597c991331106308faecb7905191bfdf41d6.zip
app-vim/vimagit: initial import
Diffstat (limited to 'app-vim/vimagit/vimagit-9999.ebuild')
-rw-r--r--app-vim/vimagit/vimagit-9999.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-vim/vimagit/vimagit-9999.ebuild b/app-vim/vimagit/vimagit-9999.ebuild
new file mode 100644
index 000000000000..1583759b0cc2
--- /dev/null
+++ b/app-vim/vimagit/vimagit-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"