summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-08-12 23:23:37 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-08-12 23:23:37 +0000
commit6e42812f02ff339e9ec3a56547fecf97a4c41a1d (patch)
treeeb5ad6fd558ec59205ccc7dbb865a39d968b6e28 /app-vim/xquery-syntax
parentdev-libs/libpcre-debian: New package, required by some binaries (diff)
downloadgentoo-6e42812f02ff339e9ec3a56547fecf97a4c41a1d.tar.gz
gentoo-6e42812f02ff339e9ec3a56547fecf97a4c41a1d.tar.bz2
gentoo-6e42812f02ff339e9ec3a56547fecf97a4c41a1d.zip
app-vim/xquery-syntax: EAPI 6 bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/xquery-syntax')
-rw-r--r--app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild b/app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild
new file mode 100644
index 000000000000..4da686912fca
--- /dev/null
+++ b/app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: XQuery syntax highlighting"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=803"
+
+LICENSE="vim.org"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for XQuery files."
+
+src_prepare() {
+ default
+ # use hi def link. Bug #101788, bug #101804.
+ sed -i -e 's,^hi\(ghlight\)\? link,hi def link,' syntax/xquery.vim \
+ || die "sed failed"
+}