summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-07-03 22:22:37 -0400
committerAaron Bauman <bman@gentoo.org>2020-07-03 22:24:06 -0400
commit17ed872c6334185fdebf3d60b2aa219fc1fe7516 (patch)
tree12e8c60e602df8f5c29d00e701eab0a16ede9847 /app-vim
parentmedia-plugins/kodi-pvr-nextpvr: 3.3.21 version bump (diff)
downloadgentoo-17ed872c6334185fdebf3d60b2aa219fc1fe7516.tar.gz
gentoo-17ed872c6334185fdebf3d60b2aa219fc1fe7516.tar.bz2
gentoo-17ed872c6334185fdebf3d60b2aa219fc1fe7516.zip
*/*: drop last-rited py2 packages
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/easytags/Manifest1
-rw-r--r--app-vim/easytags/easytags-3.11-r1.ebuild50
-rw-r--r--app-vim/easytags/easytags-3.11.ebuild40
-rw-r--r--app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch54
-rw-r--r--app-vim/easytags/metadata.xml11
-rw-r--r--app-vim/notes/Manifest1
-rw-r--r--app-vim/notes/metadata.xml11
-rw-r--r--app-vim/notes/notes-0.33.4-r1.ebuild35
8 files changed, 0 insertions, 203 deletions
diff --git a/app-vim/easytags/Manifest b/app-vim/easytags/Manifest
deleted file mode 100644
index 1cd43cb38f27..000000000000
--- a/app-vim/easytags/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST easytags-3.11.tar.gz 40572 BLAKE2B a6b228743f493bd467aff6685b6799de7e4862d384e14c81a084d7a211cf165d62cf902415a3c98a69858eded64c606bd4565f6e0c43fab7c078ba81d0ec5217 SHA512 9c1985a02b2718315d825ed29c06cbf78050e693893a9a7530a774031cbe9e6a27ee1dc91878950a1fbcaf7ea685faeb799d1e5b218b9ce25718783409f66130
diff --git a/app-vim/easytags/easytags-3.11-r1.ebuild b/app-vim/easytags/easytags-3.11-r1.ebuild
deleted file mode 100644
index cbd424d4f07a..000000000000
--- a/app-vim/easytags/easytags-3.11-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-
-inherit python-single-r1 vim-plugin
-
-DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
-HOMEPAGE="http://peterodding.com/code/vim/easytags/"
-SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- app-vim/vim-misc
- dev-util/ctags"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-S="${WORKDIR}/vim-${P}"
-
-PATCHES=( "${FILESDIR}/${P}-fix-ctags-detection.patch" )
-
-src_prepare() {
- default
- rm addon-info.json INSTALL.md README.md || die
-}
-
-src_install() {
- vim-plugin_src_install
-
- fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
-
- # fix scripts
- local f
- for f in $(find "${ED}" -type f -name \*.py); do
- ebegin "Fixing $(basename ${f})"
- if [[ $f =~ highlight.py ]]; then
- sed -e '1 i\#!/usr/bin/env python3' -i "${f}" || die "can't sed patch ${f}"
- fi
- 2to3 -w -n --no-diffs "${f}" >& /dev/null || die "can't convert ${f} to Python 3"
- python_fix_shebang -q -f "${f}"
- eend $?
- done
-}
diff --git a/app-vim/easytags/easytags-3.11.ebuild b/app-vim/easytags/easytags-3.11.ebuild
deleted file mode 100644
index 3b3fa9986ce5..000000000000
--- a/app-vim/easytags/easytags-3.11.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1 vim-plugin
-
-DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
-HOMEPAGE="http://peterodding.com/code/vim/easytags/"
-SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="amd64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=app-vim/vim-misc-1.17.6
- dev-util/ctags"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-S="${WORKDIR}/vim-${P}"
-
-PATCHES=( "${FILESDIR}/${P}-fix-ctags-detection.patch" )
-
-src_prepare() {
- default
- # remove unnecessary files
- rm addon-info.json INSTALL.md README.md || die
-}
-
-src_install() {
- vim-plugin_src_install
-
- # fix scripts
- fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
- python_fix_shebang "${ED}"/usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
-}
diff --git a/app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch b/app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch
deleted file mode 100644
index 56b24dfe406f..000000000000
--- a/app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From f5746bdfd9942b00c349e53f3f4917ae73bb6797 Mon Sep 17 00:00:00 2001
-From: Mathias Andersson <wraul@dbox.se>
-Date: Thu, 24 Dec 2015 14:24:34 +0100
-Subject: [PATCH] Fix detection of Universal Ctags.
-
-Recently Universal Ctags changed version from 'Development' to '0.0.0'
-which broke the detection.
----
- autoload/xolox/easytags.vim | 32 +++++++++++++++++++-------------
- 1 file changed, 19 insertions(+), 13 deletions(-)
-
-diff --git a/autoload/xolox/easytags.vim b/autoload/xolox/easytags.vim
-index d0dec21..3c85e6a 100644
---- a/autoload/xolox/easytags.vim
-+++ b/autoload/xolox/easytags.vim
-@@ -78,19 +78,25 @@ function! xolox#easytags#check_ctags_compatible(name, min_version) " {{{2
- call xolox#misc#msg#debug("easytags.vim %s: Command '%s' returned nonzero exit code %i!", g:xolox#easytags#version, a:name, result['exit_code'])
- else
- " Extract the version number from the output.
-- let pattern = '\(Exuberant\|Universal\) Ctags \zs\(\d\+\(\.\d\+\)*\|Development\)'
-- let g:easytags_ctags_version = matchstr(get(result['stdout'], 0, ''), pattern)
-- " Deal with development builds.
-- if g:easytags_ctags_version == 'Development'
-- call xolox#misc#msg#debug("easytags.vim %s: Assuming development build is compatible ..", g:xolox#easytags#version, a:name)
-- return 1
-- endif
-- " Make sure the version is compatible.
-- if xolox#misc#version#at_least(a:min_version, g:easytags_ctags_version)
-- call xolox#misc#msg#debug("easytags.vim %s: Version is compatible! :-)", g:xolox#easytags#version)
-- return 1
-- else
-- call xolox#misc#msg#debug("easytags.vim %s: Version is not compatible! :-(", g:xolox#easytags#version)
-+ let pattern = '\(\w\+\) Ctags \(\d\+\(\.\d\+\)*\|Development\)'
-+ let match = matchlist(get(result['stdout'], 0, ''), pattern)
-+ let g:easytags_ctags_fork = match[1]
-+ let g:easytags_ctags_version = match[2]
-+ if g:easytags_ctags_fork != '' && g:easytags_ctags_version != ''
-+ call xolox#misc#msg#debug("easytags.vim %s: Detected %s Ctags %s", g:xolox#easytags#version, g:easytags_ctags_fork, g:easytags_ctags_version)
-+ if g:easytags_ctags_fork == 'Universal'
-+ " All versions should be compatible.
-+ call xolox#misc#msg#debug("easytags.vim %s: Assuming all versions is compatible ..", g:xolox#easytags#version)
-+ return 1
-+ elseif g:easytags_ctags_fork == 'Exuberant'
-+ " Make sure the version is compatible.
-+ if xolox#misc#version#at_least(a:min_version, g:easytags_ctags_version)
-+ call xolox#misc#msg#debug("easytags.vim %s: Version is compatible! :-)", g:xolox#easytags#version)
-+ return 1
-+ else
-+ call xolox#misc#msg#debug("easytags.vim %s: Version is not compatible! :-(", g:xolox#easytags#version)
-+ endif
-+ endif
- endif
- endif
- call xolox#misc#msg#debug("easytags.vim %s: Standard output of command: %s", g:xolox#easytags#version, string(result['stdout']))
diff --git a/app-vim/easytags/metadata.xml b/app-vim/easytags/metadata.xml
deleted file mode 100644
index f13cee8dc033..000000000000
--- a/app-vim/easytags/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>vim@gentoo.org</email>
- <name>Gentoo Vim Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">xolox/vim-easytags</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-vim/notes/Manifest b/app-vim/notes/Manifest
deleted file mode 100644
index 096eb6ad9365..000000000000
--- a/app-vim/notes/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST notes-0.33.4.tar.gz 239372 BLAKE2B f326c5d6adf25cce9261ac555541261750926c55f73d3a3f57885f7f03f9fae97e03f20882cb74f5fcd78b1ec06c2e0a5b1eb977aadf6a9771c679205a4a48e9 SHA512 7f2147e786582e69760c6d76d7144bc1fd0f8934ce6574184e16f463f5ca9c21e9e0fc87f88b56922b8195b26be7b0f99435cef773ccbc360077cf568b98b98a
diff --git a/app-vim/notes/metadata.xml b/app-vim/notes/metadata.xml
deleted file mode 100644
index 2e0c837525af..000000000000
--- a/app-vim/notes/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>vim@gentoo.org</email>
- <name>Gentoo Vim Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">xolox/vim-notes</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-vim/notes/notes-0.33.4-r1.ebuild b/app-vim/notes/notes-0.33.4-r1.ebuild
deleted file mode 100644
index d436975d1828..000000000000
--- a/app-vim/notes/notes-0.33.4-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-
-PYTHON_REQ_USE="sqlite"
-
-inherit vim-plugin python-single-r1
-
-DESCRIPTION="vim plugin: easy note taking in vim"
-HOMEPAGE="http://peterodding.com/code/vim/notes/"
-SRC_URI="https://github.com/xolox/vim-notes/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- app-vim/vim-misc"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-S="${WORKDIR}/vim-${P}"
-
-src_prepare() {
- default
-
- # remove unnecessary files
- rm addon-info.json INSTALL.md README.md || die
-
- python_fix_shebang "${S}"
-}