summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-04-20 23:33:08 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-04-21 22:44:51 +0200
commit22d5270c1d547bf47fcbbdb32725077accfb0896 (patch)
treef8bb9225e53f693198695fe59b5dacb597f52edb /app-vim
parentdev-php/pecl-amqp: Add missing ssl USE requirement on rabbitmq-c (diff)
downloadgentoo-22d5270c1d547bf47fcbbdb32725077accfb0896.tar.gz
gentoo-22d5270c1d547bf47fcbbdb32725077accfb0896.tar.bz2
gentoo-22d5270c1d547bf47fcbbdb32725077accfb0896.zip
app-vim/pydiction: convert to python-r1.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/pydiction/pydiction-1.2.3-r1.ebuild b/app-vim/pydiction/pydiction-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..1c606af310f3
--- /dev/null
+++ b/app-vim/pydiction/pydiction-1.2.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit vim-plugin python-r1
+
+DESCRIPTION="vim plugin: tab-complete your Python code"
+HOMEPAGE="https://rkulla.github.io/pydiction/"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+LICENSE="vim"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}-master"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ local pyfiles=( complete-dict pydiction.py )
+ doins "${pyfiles[@]}"
+ rm -v "${pyfiles[@]}" || die
+ vim-plugin_src_install
+}