summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-21 18:46:11 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-27 17:19:22 +0200
commit4b64f217d2ca061cdb9b659dd15fb3fd738bd373 (patch)
treee57909fe81a358cbe6101ffe7e02b29650c5c9f6 /app-vim
parentapp-vim/vimpress: Add missing PYTHON_USEDEP on markdown (diff)
downloadgentoo-4b64f217d2ca061cdb9b659dd15fb3fd738bd373.tar.gz
gentoo-4b64f217d2ca061cdb9b659dd15fb3fd738bd373.tar.bz2
gentoo-4b64f217d2ca061cdb9b659dd15fb3fd738bd373.zip
app-vim/voom: Port to python-single-r1
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/voom/voom-5.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/voom/voom-5.1-r1.ebuild b/app-vim/voom/voom-5.1-r1.ebuild
new file mode 100644
index 000000000000..b09489346009
--- /dev/null
+++ b/app-vim/voom/voom-5.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: emulates a two-pane text outliner"
+HOMEPAGE="https://vim-voom.github.com/ http://www.vim.org/scripts/script.php?script_id=2657"
+
+LICENSE="CC0-1.0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )"