summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-07 02:43:27 +0000
committerSam James <sam@gentoo.org>2021-12-07 02:45:03 +0000
commit4d119351be58d01b2ccb9a3a012e7034ebb24176 (patch)
tree95c970aa2838add451f9f03d2f915bbaae2c0d92 /app-vim
parentapp-vim/lustyexplorer: add 5.0 (diff)
downloadgentoo-4d119351be58d01b2ccb9a3a012e7034ebb24176.tar.gz
gentoo-4d119351be58d01b2ccb9a3a012e7034ebb24176.tar.bz2
gentoo-4d119351be58d01b2ccb9a3a012e7034ebb24176.zip
app-vim/bash-support: add 4.3
Going through some app-vim/* bump bugs given upstream seem to be deprecating and removing some old functionality, this is needed to keep things working. Closes: https://bugs.gentoo.org/808769 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/bash-support/Manifest1
-rw-r--r--app-vim/bash-support/bash-support-4.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/bash-support/Manifest b/app-vim/bash-support/Manifest
index 6efbb45f6d48..129a59a5bb27 100644
--- a/app-vim/bash-support/Manifest
+++ b/app-vim/bash-support/Manifest
@@ -1 +1,2 @@
DIST bash-support-4.2.1.tar.bz2 115200 BLAKE2B 2fab4f1bb0897af389a206051e63d2fe7a8cd89367298b1be51146eed7c0d788b23cec7bc81ce3056d26b5efc920043e67be003e4e6bfe25b503d532c74d9c07 SHA512 12ab39f5cffb58e4adb2137265d6c4f1a61b5f2e360f6866c21ead0a67e02a5445bd12fec5b00b26e5d6102b3aaab99b8b13539a67575067c3ef9b26c4ef8fba
+DIST bash-support-4.3.zip 249238 BLAKE2B 46fa031b4ba927e5a229fa9dc93a3dbe005322a1de494bc8cbeb56138f2c580ea5b39b203d46b59013e1985930422c2e4217234a317fbf8ee6209889c4047323 SHA512 fd9294e467129990bc9796cda309a5b0ec5af3ddbda7f141939622ec0d96c1573b35d9a20e99040d6a4e83b1e98c1f6b847c77d055cca9492922e1080dc64118
diff --git a/app-vim/bash-support/bash-support-4.3.ebuild b/app-vim/bash-support/bash-support-4.3.ebuild
new file mode 100644
index 000000000000..6de7fb8f0321
--- /dev/null
+++ b/app-vim/bash-support/bash-support-4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: write and run bash scripts using menus and hotkeys"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=365"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=24452 -> ${P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc doc/{ChangeLog,bash-hotkeys.pdf}
+ rm -rf ${PN}/doc || die
+
+ vim-plugin_src_install
+}