summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-27 23:50:47 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-27 23:51:05 +0100
commit6136ecf2da97e6e997097fac597cf509a26e3b84 (patch)
tree7cd918dc59a0009963d0120347ff295f7bc2fe42 /app-vim
parentdev-python/statsmodels: version bump (diff)
downloadgentoo-6136ecf2da97e6e997097fac597cf509a26e3b84.tar.gz
gentoo-6136ecf2da97e6e997097fac597cf509a26e3b84.tar.bz2
gentoo-6136ecf2da97e6e997097fac597cf509a26e3b84.zip
app-vim/vim-autoclose: new package.
autoclose is a plugin to automatically open and close pair or characters. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vim-autoclose/Manifest1
-rw-r--r--app-vim/vim-autoclose/metadata.xml12
-rw-r--r--app-vim/vim-autoclose/vim-autoclose-2.0.ebuild21
3 files changed, 34 insertions, 0 deletions
diff --git a/app-vim/vim-autoclose/Manifest b/app-vim/vim-autoclose/Manifest
new file mode 100644
index 000000000000..01e1985f65a2
--- /dev/null
+++ b/app-vim/vim-autoclose/Manifest
@@ -0,0 +1 @@
+DIST vim-autoclose-2.0.tar.gz 35779 SHA256 151cfbfda66f338c63e59aad47c7ae34de96d62628fc48af12b0894771f913d2 SHA512 2604c2c16f25eb60bf660ba4f80d40d9aa51af38cc59a2727f0c705ba2abe5302a58dc60a71c791cc6aa002477587d1dadcc8a9269a93c5a9405a86251f4fcd9 WHIRLPOOL 1a0588cb29c4d9d8fa8c9d97d3bcfe0da61e7a9657f1c2127053cd4f57a086f52139f8b2f689126db320f94a612a05714fa486958c98c645f4450b78c929e17c
diff --git a/app-vim/vim-autoclose/metadata.xml b/app-vim/vim-autoclose/metadata.xml
new file mode 100644
index 000000000000..8fafbfec1948
--- /dev/null
+++ b/app-vim/vim-autoclose/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild b/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild
new file mode 100644
index 000000000000..f3f5770eb2e1
--- /dev/null
+++ b/app-vim/vim-autoclose/vim-autoclose-2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: open-close pair of characters"
+HOMEPAGE="https://github.com/Townk/vim-autoclose"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv * "${P}" || die
+}