summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-23 13:27:12 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-25 01:50:50 -0400
commit7282bee5376bd3bd50a4612b912340be90fdbe77 (patch)
treea8887aac6725b3afcdea5f0788a5ed87da677140 /app-vim
parentdev-ruby/http-cookie: amd64 stable, bug 658782 (diff)
downloadgentoo-7282bee5376bd3bd50a4612b912340be90fdbe77.tar.gz
gentoo-7282bee5376bd3bd50a4612b912340be90fdbe77.tar.bz2
gentoo-7282bee5376bd3bd50a4612b912340be90fdbe77.zip
app-vim/fugitive: version bump to 2.3
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/fugitive/Manifest1
-rw-r--r--app-vim/fugitive/fugitive-2.3.ebuild22
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild4
3 files changed, 25 insertions, 2 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
index 25be0b84b7f8..d439d3ff431a 100644
--- a/app-vim/fugitive/Manifest
+++ b/app-vim/fugitive/Manifest
@@ -1 +1,2 @@
DIST fugitive-2.2.tar.gz 30651 BLAKE2B 7e6ecf372661afcfa586097e979c996f19df85bf41d3b2409e26fe9131a48c02946614a15231accecbe8906a458698f89b66cc86f3707f2f7014e00d795786fe SHA512 763fc352e495dae6346fdedee5e3993a11fe402dbad0e9ee4b002b6b416404c46b56a061b3d9e663174b371d2d62e62e22f5a2cf8767fb6aee28b236c77d9d41
+DIST fugitive-2.3.tar.gz 30949 BLAKE2B ff62ad9f5b85fff6a06fe006884901ca0f80a5ee139032955a6af596cadf3dca18d73980da12429706102cbe8105fcbff5fb1dd6375b851f978746a5251f1d22 SHA512 8a176705c0326ac034abaf23423e58d490feb7f11dc45ad23641fafb95279094ed38475a90e7c2e7fc95c615558db75f3587740e2658f3988fa07a1957aa1039
diff --git a/app-vim/fugitive/fugitive-2.3.ebuild b/app-vim/fugitive/fugitive-2.3.ebuild
new file mode 100644
index 000000000000..3ec007ea68be
--- /dev/null
+++ b/app-vim/fugitive/fugitive-2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
index 5f7552c24ee8..3ec007ea68be 100644
--- a/app-vim/fugitive/fugitive-9999.ebuild
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit vim-plugin
if [[ ${PV} == 9999 ]]; then
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]]; then
else
inherit vcs-snapshot
SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
fi
DESCRIPTION="vim plugin: a git wrapper for vim"