summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-11 23:54:19 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-12 02:24:40 -0600
commit9e239ae317f45845028be8526c0e58d45be54ef4 (patch)
tree31f13db9fe2cea600c3c8db0f1fe7d7dcac12568 /app-vim
parentapp-vim/undotree: remove old (diff)
downloadgentoo-9e239ae317f45845028be8526c0e58d45be54ef4.tar.gz
gentoo-9e239ae317f45845028be8526c0e58d45be54ef4.tar.bz2
gentoo-9e239ae317f45845028be8526c0e58d45be54ef4.zip
app-vim/diffchar: version bump to 8.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/diffchar/Manifest1
-rw-r--r--app-vim/diffchar/diffchar-8.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/diffchar/Manifest b/app-vim/diffchar/Manifest
index ca186e4de1c3..f4b3be54a6df 100644
--- a/app-vim/diffchar/Manifest
+++ b/app-vim/diffchar/Manifest
@@ -1,2 +1,3 @@
DIST diffchar-7.01.tar.bz2 19950 BLAKE2B a014fa17e5b15179a4baa8e2cd4fcce36f1cc66cbd8c4ab3a13c0288a510b74f06105d2034666669e2bac2881f5bc5cd81aa1cabb3b80a91f3d67a3bf62bd916 SHA512 3f42f40ec27262f76058d9461ccde80c5badc61d0854c1ff239bea399c26e20eb5cf8960b76901223e937097e18dd7e015fc14a8f7a99907666c518d4baf5117
DIST diffchar-7.2.tar.bz2 20092 BLAKE2B 20eef77d7019e55e466e1212e4560d91cde83f55808a4b77eb6fe2e5b7518715606d8d89c046e453dcb380517163974e173e00c18d662df2ee8ae43a6a347c06 SHA512 7c9a9239ae4eae1d325984ab40ae8d90e2dabf96dc929ed6f05c3496352aeb562452bd154fe3d1ec96353356c287604162f5b89d762b7afe26bc975449d92427
+DIST diffchar-8.1.tar.gz 440558 BLAKE2B d10e1db0db4b475af34a268324bec6f8fa1248124df2a40716406d207633f3ca0ef64e2b0673a21c24673c8d0640de936d897a9adfdebbe033ad7c4b10e9648d SHA512 4457b2f769049999c13a2a7ea5a585ba081ab18234c7bcda28e22a481b807edc0c4183229ad7239bc9d10b27270b35c6f27f27f92637693ee869eff09c22fc63
diff --git a/app-vim/diffchar/diffchar-8.1.ebuild b/app-vim/diffchar/diffchar-8.1.ebuild
new file mode 100644
index 000000000000..b3395586f7c4
--- /dev/null
+++ b/app-vim/diffchar/diffchar-8.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin vcs-snapshot
+
+GIT_HASH="057dad8c90d72af5d9bca9cd33746c3b59285191"
+
+DESCRIPTION="vim plugin: highlight the exact differences, based on characters and words"
+HOMEPAGE="https://github.com/rickhowe/diffchar.vim https://www.vim.org/scripts/script.php?script_id=4932"
+SRC_URI="https://github.com/rickhowe/diffchar.vim/archive/${GIT_HASH}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm *.gif *.png *.md || die
+}