summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-01 11:34:15 +0000
committerSam James <sam@gentoo.org>2021-06-01 11:34:15 +0000
commitb4f954a75f9a8bcf66af8fb0bd5c6a3e161d74f2 (patch)
treecd8151b61c561236b81bd04a8a4fa4a4ffcbfc5f /app-vim
parentdev-libs/criterion: add GCC 11 patch (diff)
downloadgentoo-b4f954a75f9a8bcf66af8fb0bd5c6a3e161d74f2.tar.gz
gentoo-b4f954a75f9a8bcf66af8fb0bd5c6a3e161d74f2.tar.bz2
gentoo-b4f954a75f9a8bcf66af8fb0bd5c6a3e161d74f2.zip
app-vim/pyclewn: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/pyclewn/pyclewn-2.1-r2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/app-vim/pyclewn/pyclewn-2.1-r2.ebuild b/app-vim/pyclewn/pyclewn-2.1-r2.ebuild
index 5c6b40215115..ac33eb0aeb32 100644
--- a/app-vim/pyclewn/pyclewn-2.1-r2.ebuild
+++ b/app-vim/pyclewn/pyclewn-2.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit vim-plugin distutils-r1 optfeature
@@ -11,10 +11,10 @@ SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
HOMEPAGE="http://pyclewn.sourceforge.net/"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
CDEPEND="|| (
app-editors/vim
@@ -25,8 +25,7 @@ DEPEND="
${CDEPEND}
app-arch/vimball"
-RDEPEND="
- ${DEPEND}"
+RDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"