summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 17:26:57 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 18:03:57 +0100
commitb986133661fa4633ba2c807d89091ec32c378587 (patch)
treea21023981627f5ff3b0911add76c6e446db716ed /app-vim
parentapp-vim/gentoo-syntax: Reset version numbers (diff)
downloadgentoo-b986133661fa4633ba2c807d89091ec32c378587.tar.gz
gentoo-b986133661fa4633ba2c807d89091ec32c378587.tar.bz2
gentoo-b986133661fa4633ba2c807d89091ec32c378587.zip
app-vim/gentoo-syntax: Bump to v1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 48127840a21d..33e8f637344c 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,2 +1,3 @@
+DIST gentoo-syntax-1.tar.bz2 20223 BLAKE2B 846e07354660b4859cc4131a9fbf4f78d3a2ddeda60fc6a3687b649788a52725602dcd22befa9ab9fe88b173eab1470e569076d587326935efaf40d3aaba5b57 SHA512 1e4d947f0edbf6bd24142d683944f30d43b7e0ca86b90311f2e80516d299d9a634a9842cdc90d98a43e7a693f0dd29b3ff8048256bc3fe688591cc2b84808289
DIST gentoo-syntax-20211208.tar.bz2 18844 BLAKE2B 52e7025d46f5101f2e1c44afcbf3cba0756a1ec9c626f7af312bb5bbae518645c06c94bfc48822a721e2e3c1ed5f61376e88a074a9688cf4b5b3c352a99c87c9 SHA512 f1cfe2af440f7ed3042cbaa16558cb6df8038f439a2c3e7067f81751a37098854a3afb1653c7c3656ef85ad1874d2db9271429b92a25f494da6ee5c68819e631
DIST gentoo-syntax-20220220.tar.bz2 19433 BLAKE2B 8f7fbbb56e41f4d682c824deb980035441195785f9ce80fd45808b55cf900c8e0455b5c670f82b1fc639c052792b78de5f0be1142eab853b0cabbd44c6ed0776 SHA512 4b515ca7936a16279c48310d1fa0f58979e35b1d84a2971bdcf4a004784efa3de99619851ac9da5ee0ee77a1f65eb28550d01013cffebd45e39fb70c0136ba12
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-1.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-1.ebuild
new file mode 100644
index 000000000000..3cc000eb8ff3
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+MY_P=${P/0.}
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}