summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-16 18:11:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-16 18:16:12 +0100
commitbc5cfe2adcbbbfd2217a6f7ccb849c389f8f4458 (patch)
tree3ad059775354fe8a5d1d27defb504850c8aaa4bc /app-vim
parentsys-apps/plocate: remove unused patch (diff)
downloadgentoo-bc5cfe2adcbbbfd2217a6f7ccb849c389f8f4458.tar.gz
gentoo-bc5cfe2adcbbbfd2217a6f7ccb849c389f8f4458.tar.bz2
gentoo-bc5cfe2adcbbbfd2217a6f7ccb849c389f8f4458.zip
app-vim/gentoo-syntax: Bump to 20211116
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index e94ffd19d1f4..9b4aa5cd1208 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1 +1,2 @@
DIST gentoo-syntax-20210911.tar.bz2 18865 BLAKE2B 14dfe4b1eaab39a7de11c9b2e00c6a39385cd81d5717522dbac1f9ff265047c9ded745c335cca88413f6ad622f2858d996bdb39c5f4b1b4796ef7740c48c5f68 SHA512 b7ac7aba50c086e1e550692426bb38dbca5bf4770c148ff4989686ef043a2d990710bec782f1baba582ff67da3b3db007a4dbc6dec16f69830312205f1a45d3c
+DIST gentoo-syntax-20211116.tar.bz2 18849 BLAKE2B 7d9ebe080d09dc604a0847285d1cda90d4d5538360bce122bba054b66e2be9afcd8fed7098664447e0f07adc1ae6c4feff08e48884995fbbe3abd925e5d7bf67 SHA512 ff13926998e6d5b530bdf7ab8a6427264980d194b13c16811cc6380b0aa4edc7445ffa157afe3c19b536bcd42208d85a36e92921b1c2c8c3e4c136295b00f770
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild
new file mode 100644
index 000000000000..72f25ef766b6
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}