summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-03 09:37:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-03 09:37:55 +0100
commitd1f8740326287105db2004f87eba30b791e6cdd2 (patch)
treec0c59b63b07a81338c80954030fb9e57d3dd6543 /app-vim
parentdev-python/httplib2: Bump to 0.20.4 (diff)
downloadgentoo-d1f8740326287105db2004f87eba30b791e6cdd2.tar.gz
gentoo-d1f8740326287105db2004f87eba30b791e6cdd2.tar.bz2
gentoo-d1f8740326287105db2004f87eba30b791e6cdd2.zip
app-vim/gentoo-syntax: Bump to 20220203
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20220203.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 6948e9f4b72e..0b32eea54552 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-syntax-20211208.tar.bz2 18844 BLAKE2B 52e7025d46f5101f2e1c44afcbf3cba0756a1ec9c626f7af312bb5bbae518645c06c94bfc48822a721e2e3c1ed5f61376e88a074a9688cf4b5b3c352a99c87c9 SHA512 f1cfe2af440f7ed3042cbaa16558cb6df8038f439a2c3e7067f81751a37098854a3afb1653c7c3656ef85ad1874d2db9271429b92a25f494da6ee5c68819e631
DIST gentoo-syntax-20220126.tar.bz2 19267 BLAKE2B c18f50e29f4aa75e4cc8d629b5086de3cef629b99454389bfe5eecbc61288e4344921360a2d64ea021be7f0269178e6348abf0d1481e0fc8b88e16a16fb73215 SHA512 bbedf2bf98eaf7b80abac2e6a66dcbba2f5024f1a4327535e5d956c4c034fa9be0395a36784a576caeaee81df27eb153687238388bfc2aeaf210498d8377c99d
+DIST gentoo-syntax-20220203.tar.bz2 19323 BLAKE2B e9947e6deefcb6974ef97c0ad2057b9d5052907a3f30ebce6d59cbf69a7555c1f1466eb896ffc669dcc8ddd8719037f5bca7ecac2a5d9f3a299710086ada95b3 SHA512 749943ed2edec9ac8285a88d551bc18ff386b23981d4aa233a4206688d2e3903804f5ea92a4476c6bfc04641c1fc4952c6c4980b5059df80cb6fbccc5469040c
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20220203.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20220203.ebuild
new file mode 100644
index 000000000000..cc256f13f274
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20220203.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}