summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-21 16:32:49 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-21 16:57:52 +0200
commitd999abeb879764bb95115ff8ced8a982dae17a01 (patch)
treed23e26d5e6f29cd31e3c7c0a2334a5fea41df1ed /app-vim
parentapp-vim/pyclewn: add python{3_7,3_8} targets. (diff)
downloadgentoo-d999abeb879764bb95115ff8ced8a982dae17a01.tar.gz
gentoo-d999abeb879764bb95115ff8ced8a982dae17a01.tar.bz2
gentoo-d999abeb879764bb95115ff8ced8a982dae17a01.zip
app-vim/pyclewn: clean up old.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/pyclewn/pyclewn-2.1-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild b/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
deleted file mode 100644
index 67459d86ff7e..000000000000
--- a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit eutils vim-plugin distutils-r1
-
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
-HOMEPAGE="http://pyclewn.sourceforge.net/"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="|| (
- >=app-editors/vim-7.3
- >=app-editors/gvim-7.3[netbeans]
-)"
-
-DEPEND="
- ${CDEPEND}
- app-arch/vimball"
-
-RDEPEND="
- ${DEPEND}"
-
-SLOT="0"
-
-#Completely broken (runs vim), disable for now
-#python_test() {
-# esetup.py test
-#}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
-}
-
-pkg_postinst() {
- vim-plugin_pkg_postinst
-
- optfeature "C/C++ debugging" sys-devel/gdb
- optfeature "Python debugging" dev-python/pdb-clone
-}