summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-12-13 09:31:04 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-12-13 09:31:04 +0100
commitff1103ae9dcf65162dd8a2a8549b90601aa6c05e (patch)
tree26d71cbece4efee1bc27b90631a38690eede75e8 /app-vim
parentapp-vim/splice: clean up old. (diff)
downloadgentoo-ff1103ae9dcf65162dd8a2a8549b90601aa6c05e.tar.gz
gentoo-ff1103ae9dcf65162dd8a2a8549b90601aa6c05e.tar.bz2
gentoo-ff1103ae9dcf65162dd8a2a8549b90601aa6c05e.zip
app-vim/splice: add python3.6 support.
Closes: https://bugs.gentoo.org/658840 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/splice/splice-1.1.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/splice/splice-1.1.0-r1.ebuild b/app-vim/splice/splice-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..3753a52afbed
--- /dev/null
+++ b/app-vim/splice/splice-1.1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_6 )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: resolve conflicts during three-way merges"
+HOMEPAGE="https://bitbucket.org/sjl/splice.vim/ https://www.vim.org/scripts/script.php?script_id=4026"
+SRC_URI="https://bitbucket.org/sjl/${PN}.vim/get/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm .[a-z]* Makefile LICENSE.markdown package.sh || die
+ rm -r site || die
+}
+
+src_install() {
+ vim-plugin_src_install
+ python_optimize "${ED}"/usr/share/vim/vimfiles/autoload/splicelib
+}