summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-02-27 19:17:35 +0100
committerUlrich Müller <ulm@gentoo.org>2023-02-27 19:17:35 +0100
commite41718d5112932cfdaf70ce151d035642199ee69 (patch)
treefb177e6a9647c27f956258abcce786d131f7b1c5 /app-xemacs
parentapp-emacs/ebuild-mode: add 1.62 (diff)
downloadgentoo-e41718d5112932cfdaf70ce151d035642199ee69.tar.gz
gentoo-e41718d5112932cfdaf70ce151d035642199ee69.tar.bz2
gentoo-e41718d5112932cfdaf70ce151d035642199ee69.zip
app-xemacs/ebuild-mode: add 1.62
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-xemacs')
-rw-r--r--app-xemacs/ebuild-mode/Manifest1
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.62.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/Manifest b/app-xemacs/ebuild-mode/Manifest
index b28c0b65bc0f..c4e9670ac7d0 100644
--- a/app-xemacs/ebuild-mode/Manifest
+++ b/app-xemacs/ebuild-mode/Manifest
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.60.tar.xz 36996 BLAKE2B a566c9f602ec6ac4126a4a13610e515faf2a02b8ca89f417a037a28f4b9ea633518d589d78f6deb54084be34cdc30c2a1896546b2f86c1166cedd47289edcfd8 SHA512 b04b37b7a376dc48a7f80ec0e60bf36a8b7ea92edcbdd45fbd002e80e8ea29111905a726177a869d607adffe78094efcdc94b1aad32afe1444a09b4e714dcecd
DIST ebuild-mode-1.61.tar.xz 38632 BLAKE2B f13f251918cf13533611c4d98a9aeceff10e9253c207a10c047c59952d6c8e50cdddb7c3ff65ed7b9565bd09fb45203c9cb57a277165b9cc7bbb47c5d8978a59 SHA512 a7087894299c3882ff0993a1a33cd192ebec078e7cea2f8964610d758a439350dcf36fe43aa43a42b89446d36b62a9b80bfce531e701b0183f3d69e56528ab62
+DIST ebuild-mode-1.62.tar.xz 39080 BLAKE2B 91bb206f7ca3fecebc80d946d5840ce6e02610171d6179d360b188e270226e4f1dbe4ceddbc1e41f8e627c787b28454a20720d563bbabcffb3a99b7b10a1251d SHA512 9e7caafb45a7538dd66221d2a5dd9fef764c72f6f42db1ad1615e4017b7d4db14dcde09edfa0e8777a528af918e219521072040215d05a9c8a5cdc57ca395bd8
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.62.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.62.ebuild
new file mode 100644
index 000000000000..89d7b413d785
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.62.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ local XEMACS="${EPREFIX}/usr/bin/xemacs"
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(setq autoload-package-name \"${PN}\")" \
+ -eval "(setq generated-autoload-file \"${S}/auto-autoloads.el\")" \
+ -l autoload -f batch-update-autoloads \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}
+
+src_install() {
+ insinto /usr/share/xemacs/site-packages/lisp/${PN}
+ doins *.el *.elc
+}
+
+pkg_postinst() {
+ optfeature "ebuild commands support" sys-apps/portage
+ optfeature "additional development tools" dev-util/pkgdev
+ optfeature "ebuild QA utilities" dev-util/pkgcheck
+}