summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-05-22 20:42:42 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-05-22 20:42:42 +0200
commit1203b45baf8ad18501f6ec1e056007c4f6e32633 (patch)
tree685cd6c530e54b294584aaa9eae6be83d744d673 /dev-ada/aws/aws-2020.ebuild
parentdev-scheme/guile-sqlite3: add QA CFLAGS workaround, bug #724074 (diff)
downloadgentoo-1203b45baf8ad18501f6ec1e056007c4f6e32633.tar.gz
gentoo-1203b45baf8ad18501f6ec1e056007c4f6e32633.tar.bz2
gentoo-1203b45baf8ad18501f6ec1e056007c4f6e32633.zip
dev-ada/aws: Version bump to 2020
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada/aws/aws-2020.ebuild')
-rw-r--r--dev-ada/aws/aws-2020.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ada/aws/aws-2020.ebuild b/dev-ada/aws/aws-2020.ebuild
new file mode 100644
index 000000000000..9efa0313e567
--- /dev/null
+++ b/dev-ada/aws/aws-2020.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ADA_COMPAT=( gnat_2019 )
+inherit ada multiprocessing
+
+MYP=${P}-20200429-19A9F-src
+
+DESCRIPTION="A complete Web development framework"
+HOMEPAGE="http://libre.adacore.com/tools/aws/"
+SRC_URI="https://community.download.adacore.com/v1/c1b0f6863d1a30acaee1df022a65ad11d5737a84?filename=${MYP}.tar.gz
+ -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-ada/xmlada[${ADA_USEDEP},shared,static-libs]"
+DEPEND="${RDEPEND}
+ dev-ada/asis[${ADA_USEDEP}]
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_configure() {
+ emake -j1 setup prefix=/usr ENABLE_SHARED=true \
+ GPRBUILD="/usr/bin/gprbuild -v"
+}
+
+src_compile() {
+ emake \
+ PROCESSORS=$(makeopts_jobs) \
+ GPRBUILD="/usr/bin/gprbuild -v"
+}