summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 13:48:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:17:41 +0100
commit3f0fde333881593d5136b8309206e7fb58114039 (patch)
treedc7cc0bdac3f6797a8fda2d0ca91fe25bffff306 /dev-ada/gps
parentapp-vim/youcompleteme: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-3f0fde333881593d5136b8309206e7fb58114039.tar.gz
gentoo-3f0fde333881593d5136b8309206e7fb58114039.tar.bz2
gentoo-3f0fde333881593d5136b8309206e7fb58114039.zip
dev-ada/gps: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ada/gps')
-rw-r--r--dev-ada/gps/gps-2018-r3.ebuild (renamed from dev-ada/gps/gps-2018-r2.ebuild)8
-rw-r--r--dev-ada/gps/gps-2019-r1.ebuild (renamed from dev-ada/gps/gps-2019.ebuild)8
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-ada/gps/gps-2018-r2.ebuild b/dev-ada/gps/gps-2018-r3.ebuild
index 1551312c0378..49dd272c9a9d 100644
--- a/dev-ada/gps/gps-2018-r2.ebuild
+++ b/dev-ada/gps/gps-2018-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,8 +33,10 @@ RDEPEND="${PYTHON_DEPS}
sys-devel/clang:=
x11-themes/adwaita-icon-theme
x11-themes/hicolor-icon-theme
- dev-python/pep8[${PYTHON_USEDEP}]
- dev-python/jedi[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-python/pep8[${PYTHON_MULTI_USEDEP}]
+ dev-python/jedi[${PYTHON_MULTI_USEDEP}]
+ ')"
DEPEND="${RDEPEND}"
diff --git a/dev-ada/gps/gps-2019.ebuild b/dev-ada/gps/gps-2019-r1.ebuild
index 2f20596db004..1985f108d722 100644
--- a/dev-ada/gps/gps-2019.ebuild
+++ b/dev-ada/gps/gps-2019-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,8 +38,10 @@ RDEPEND="${PYTHON_DEPS}
sys-devel/clang:=
x11-themes/adwaita-icon-theme
x11-themes/hicolor-icon-theme
- dev-python/pep8[${PYTHON_USEDEP}]
- dev-python/jedi[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-python/pep8[${PYTHON_MULTI_USEDEP}]
+ dev-python/jedi[${PYTHON_MULTI_USEDEP}]
+ ')"
DEPEND="${RDEPEND}"