summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-08-05 11:22:39 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-08-05 11:22:39 +0200
commite9188ba72be3130b5a15fde1996e07c3bac4d7f7 (patch)
tree16841b2bf7b3ef1dad0ea06abd971a88c8d8b5eb /dev-ada
parentsys-auth/pambase: Version bump (v20200805) (diff)
downloadgentoo-e9188ba72be3130b5a15fde1996e07c3bac4d7f7.tar.gz
gentoo-e9188ba72be3130b5a15fde1996e07c3bac4d7f7.tar.bz2
gentoo-e9188ba72be3130b5a15fde1996e07c3bac4d7f7.zip
dev-ada/gnatmem: build with newer binutils-libs
Closes: https://bugs.gentoo.org/735676 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/gnatmem/files/gnatmem-2019-bfd.patch29
-rw-r--r--dev-ada/gnatmem/gnatmem-2019-r1.ebuild13
2 files changed, 38 insertions, 4 deletions
diff --git a/dev-ada/gnatmem/files/gnatmem-2019-bfd.patch b/dev-ada/gnatmem/files/gnatmem-2019-bfd.patch
new file mode 100644
index 000000000000..007d217cf247
--- /dev/null
+++ b/dev-ada/gnatmem/files/gnatmem-2019-bfd.patch
@@ -0,0 +1,29 @@
+--- a/src/libaddr2line.c 2020-08-04 22:41:04.670046491 +0200
++++ b/src/libaddr2line.c 2020-08-04 22:44:55.560802332 +0200
+@@ -55,14 +55,26 @@
+ if (found)
+ return;
+
++#if defined(bfd_get_section_flags)
+ if ((bfd_get_section_flags (abfd, section) & SEC_ALLOC) == 0)
++#else
++ if ((bfd_section_flags (section) & SEC_ALLOC) == 0)
++#endif
+ return;
+
++#if defined(bfd_get_section_vma)
+ vma = bfd_get_section_vma (abfd, section);
++#else
++ vma = bfd_section_vma (section);
++#endif
+ if (pc < vma)
+ return;
+
++#if defined(bfd_get_section_size)
+ size = bfd_get_section_size (section);
++#else
++ size = bfd_section_size (section);
++#endif
+ if (pc >= vma + size)
+ return;
+
diff --git a/dev-ada/gnatmem/gnatmem-2019-r1.ebuild b/dev-ada/gnatmem/gnatmem-2019-r1.ebuild
index 44e18966d1ea..67e5964f46a9 100644
--- a/dev-ada/gnatmem/gnatmem-2019-r1.ebuild
+++ b/dev-ada/gnatmem/gnatmem-2019-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,13 +21,16 @@ IUSE=""
RDEPEND="${ADA_DEPS}"
DEPEND="${RDEPEND}
dev-ada/gprbuild[${ADA_USEDEP}]
- sys-libs/binutils-libs"
+ sys-libs/binutils-libs:="
REQUIRED_USE="${ADA_REQUIRED_USE}"
S="${WORKDIR}"/${MYP}
-PATCHES=( "${FILESDIR}"/${PN}-2018-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2018-gentoo.patch
+ "${FILESDIR}"/${P}-bfd.patch
+)
src_prepare() {
default
@@ -37,7 +40,9 @@ src_prepare() {
src_compile() {
gprbuild -v -Pgnatmem.gpr -j$(makeopts_jobs) \
- -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS}
+ -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} \
+ -largs ${LDFLAGS} \
+ || die
}
src_install() {