summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-10-16 11:08:15 +0100
committerIonen Wolkens <ionen@gentoo.org>2021-10-16 17:26:44 -0400
commiteb494cdc0dba010a65cfb21a7c4d8877ca25facc (patch)
treed596667e468a327338395464c82a039927b1b628 /dev-cpp/asio/asio-1.20.0.ebuild
parentdev-cpp/asio: drop old (diff)
downloadgentoo-eb494cdc0dba010a65cfb21a7c4d8877ca25facc.tar.gz
gentoo-eb494cdc0dba010a65cfb21a7c4d8877ca25facc.tar.bz2
gentoo-eb494cdc0dba010a65cfb21a7c4d8877ca25facc.zip
dev-cpp/asio: version 1.20.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/22601 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp/asio/asio-1.20.0.ebuild')
-rw-r--r--dev-cpp/asio/asio-1.20.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-cpp/asio/asio-1.20.0.ebuild b/dev-cpp/asio/asio-1.20.0.ebuild
new file mode 100644
index 000000000000..0b91e779c0be
--- /dev/null
+++ b/dev-cpp/asio/asio-1.20.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/boost
+ dev-libs/openssl
+ )
+"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}